Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

for n:=1 to 9 do for k:=1 to 9 do A[n,k ]:=n+k*2 сколько элементов массива А примут четное значение

10-11 класс

Ivanlili 03 февр. 2015 г., 10:40:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetikkbr
03 февр. 2015 г., 12:06:06 (9 лет назад)

т.к. к * 2 это всегда четное число, то будет ли число четное зависит только от n

получается для всех четных n числа будут четные,т.е. для

n = 2

n = 4

n = 6

n = 8

 

т.е. таких n всего 4 а для каждого n формируется 9 чисел с помощью второго цикла

поэтому получаем 4 * 9 = 36

Ответить

Другие вопросы из категории

помагите пжл, составить программу на языке ПАСКАЛЬ СОСТАВИТЬ ПРОГРАММУ СОКРАЩЕНИЯ ОДНОМЕРНОГО ЧИСЛОВОГО МАССИВА ПУТЕМ УДАЛЕНИЯ ( ВСЕХ ЭЛЕМЕНТОВ С НУЛЕВЫ

МИ ЗНАЧЕНИЯМИ . ДОПОЛНИТЕЛЬНЫЙ МАССИВ ИСПОЛЬЗОВАТЬ НЕ РАЗРЕШАЕТСЯ ) .........ЕСЛИ МОЖЕТИ ПОЯСНИТЕ СЛОВАМИ ЧТО ДЕЛАЕТ ПРОГРАММА

Читайте также

1. For i:= 0 to 15 do A[i]:= i+1;

For i:= 0 to 14 do A[i]:= A[i+1]
Задание то же самое, что и в предыдущем.

2. Дан фрагмент программы, обрабатывающий одномерный массив k размером n.
k:= A[i];
For i:= 1 to n-1 do A[i]:=A[i+1];
A[n]:= k;
Что делает данный алгоритм?

Помогите ,пожалуйста,составить блок-схему. Program qqq; Var a:array[0…9] of byte; n,k: integer; j: byte; begin readln(n); for j:=0 to 9 do a[j]:=0;

while n>0 do begin k:=n mod 10; n:=n div 10; inc (a[k]); end; for j:=0 to 9 do if a[j].0 then writeln (j, a[j]); for j:=0 to 9 do if a[j]=0 then writeln(j); end.

Зна­че­ния двух мас­си­вов A и B с ин­дек­са­ми от 1 до 100 за­да­ют­ся при по­мо­щи сле­ду­ю­ще­го фраг­мен­та про­грам­мы:for i : = 1 to

100 doA[i] : = i*i;for i : = 1 to 100 doB[i] : = A[i]-100;Сколь­ко по­ло­жи­тель­ных зна­че­ний будет в мас­си­ве B?

Как исправить for на цикл while?????

var n,k,i,t:integer; f:text;
begin
assign(f,'f1.txt');
rewrite(f);
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(f,i:3);
end;
close(f);
end.



Вы находитесь на странице вопроса "for n:=1 to 9 do for k:=1 to 9 do A[n,k ]:=n+k*2 сколько элементов массива А примут четное значение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.