Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. For i:= 0 to 15 do A[i]:= i+1;

10-11 класс

For i:= 0 to 14 do A[i]:= A[i+1]
Задание то же самое, что и в предыдущем.

2. Дан фрагмент программы, обрабатывающий одномерный массив k размером n.
k:= A[i];
For i:= 1 to n-1 do A[i]:=A[i+1];
A[n]:= k;
Что делает данный алгоритм?

Hemodan 07 апр. 2014 г., 2:38:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Greede
07 апр. 2014 г., 4:09:45 (10 лет назад)

1) 
uses crt;
var i:integer;
A:array[0..15] of integer;
begin
For i:= 0 to 15 do
A[i]:= i+1;
For i:= 0 to 14 do
A[i]:= A[i+1];
For i:=0 to 15 do
write(A[i],' ');
end.
2) Перемещает первый элемент массива в конец.

+ 0 -
Санжик
07 апр. 2014 г., 6:00:50 (10 лет назад)

k:= A[i]; Подразумевается что i=0? Не сказано просто.

+ 0 -
1982lena
07 апр. 2014 г., 6:43:44 (10 лет назад)

Начальное значение? Да, 0.

Ответить

Другие вопросы из категории

Плиз помогите с информатикой( в башке заело) ( здесь нужно использовать циклы for while или repeat);заранее спасибо)

1)Натуральное число n называется простым если оно делится только на 1 и на само себя.по соглашению 1 не считают простым числом. Проверить является ли n простым числом

2)Найдите и выведите на экран все трехзначные числа кратные 3, сумма цифр которых больше суммы цифр частного от деления их на 3

Помогите сделать блок-схему:

Вводятся a,b,c. Найти количество положительных чисел.

Два текста содержат одинаковое количество символов. Первый текст составлен в алфавите мощностью 16 символов, а второй текст - в алфавите из 256

символов. Во сколько раз количество информации во втором тексте больше, чем в первом?

Читайте также

Помогите ,пожалуйста,составить блок-схему. Program qqq; Var a:array[0…9] of byte; n,k: integer; j: byte; begin readln(n); for j:=0 to 9 do a[j]:=0;

while n>0 do begin k:=n mod 10; n:=n div 10; inc (a[k]); end; for j:=0 to 9 do if a[j].0 then writeln (j, a[j]); for j:=0 to 9 do if a[j]=0 then writeln(j); end.

Определить сколько раз исполнится тело цикла и чему будет равно значение переменной 1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;

2) S:=15; i:=5. while i<7 do begin i:=i+1 S:=S+S; end

3) S:= -6; i:=4

while i>8 do i:=i+1; S:=S * 0 .

Помоги составить блок-схему. program h7; const n=15; p=3.14; var x: array [0..n] of integer; y: array [0..n] of real

;

i,h,k:integer;

a,s,max,min,t:real;

f:text;

begin

randomize;

k:=0;

s:=0;

for i:=0 to n do

begin

x[i]:=trunc(15*random);

end;

for i:= 0 to n do

write(x[i]);

for i:=0 to n do

if (x[i]<1) then y[i]:=0.5*(2+sqr(sin(x[i]-p/4)))+exp(x[i]) else

if(x[i]>=1) and (x[i]<=10) then y[i]:=4*exp(0.62*ln(x[i]))-2*sqrt(2*x[i])+1 else

if (x[i]>10) then y[i]:=5*exp(-x[i])+2*sqr(ln(x[i]));

for i:= 0 to n do

write (y[i]:5:1);

for i:= 0 to n do

s:=s+y[i];

a:=s/i;

max:=y[0];

min:=y[0];

for i:= 0 to n do;

if y[i]/0.3>a then

begin

if y[i]>max then begin

max:=y[i];

h:=i;

end

else

if y[i]<min then begin

min:=y[i];

k:=i;

end;

end;

t:=y[h];

y[h]:=y[k];

y[k]:=t;

for i:= 0 to n do

write (y[i]:5:1);

writeln ('----------------------');

assign (f,'f.txt');

rewrite(f);

end.

Зна­че­ния двух мас­си­вов A и B с ин­дек­са­ми от 1 до 100 за­да­ют­ся при по­мо­щи сле­ду­ю­ще­го фраг­мен­та про­грам­мы:for i : = 1 to

100 doA[i] : = i*i;for i : = 1 to 100 doB[i] : = A[i]-100;Сколь­ко по­ло­жи­тель­ных зна­че­ний будет в мас­си­ве B?

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)



Вы находитесь на странице вопроса "1. For i:= 0 to 15 do A[i]:= i+1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.