Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить, счастливый ли билетик.

5-9 класс

С помощью 2 массивов. Принцип такой: на билете 6 цифр. Если сумма первых трех будет равна сумме следующих трех, то билет-счастливый.

Сакишка 17 марта 2015 г., 20:09:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rejina20039094
17 марта 2015 г., 20:58:49 (9 лет назад)

var  
s: string; 
 i, a, b, c, f: integer; 
 begin  
writeln('Номер билета?'); 
 readln(s); 
   for i := 1 to 3 do  
begin    
val(s[i], a, f);  
  b := b + a;  
end;   
 for i := 4 to 6 do  
begin    
val(s[i], a, f);   
 c := c + a;  
end;   
 if c = b then writeln('Билет счастливый!')   ;
else writeln('Билет НЕ счастливый!');  
readln ;
end.

+ 0 -
KraffTheGamer
17 марта 2015 г., 23:11:49 (9 лет назад)

и в чём тут вопрос

Ответить

Другие вопросы из категории

1.А&(BvA)

2.(AиВ) или не А

Используя генератор случайных чисел, заполнить массив размерностью 10 элементов числами из интервала [-20,+20]. Вывести список элементов массива в одну

строку с интервалом 4 пункта.

Ребят, помогите, пожалуйста, вообще не понимаю как делать)
наугад ввела кол-во баллов, не знаю , что они значат

.Найдите в списке шесть подмножеств, между которыми существуют отношения "является разновидностью". Определите в каждой такой паре имя

подмножества. Назовите для него хотя бы одно дополнительное свойство: Книга,бензин,врач,молоко,строитель,учебник,жидкость,справочник,человек

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Пожаалуйста) В программе Geany Задача 1. Определить четность/нечетность числа, введённого пользователем (использовать операцию mod,

p>которая находит остаток от деления).

Задача 2.

Определить, попадает ли введенное число x в интервал [a, b], где числа a и b тоже задаются
пользователем.

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



Вы находитесь на странице вопроса "Определить, счастливый ли билетик.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.