Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ребят!помогите с задачей на Паскаль: Определить, является ли билет счастливым

5-9 класс

Flicker 15 февр. 2015 г., 9:41:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kseniya256
15 февр. 2015 г., 10:27:48 (9 лет назад)

{$N+}
program P1;
var
n : longint;
i : longint;
d : array[1..6] of longint;

function pwr (d:longint; s:integer):longint;
var
i,q : longint;
begin

q := 1;

for i := 1 to s do
q := q * d;

pwr := q;

end;

begin

write('Nomer (6 znakov): ');


read(n);

for i := 1 to 6 do
begin


d[i] := n div pwr(10,6-i) mod 10;


end;

if d[1] + d[2] + d[3] = d[4] + d[5] + d[6] then
writeln('HAPPY TICKET!') else
writeln('NOT HAPPY :(');

readln;
readln;

end.

Ответить

Другие вопросы из категории

Сделать таблицу типа ооо оон
Написать программу.

Для целого числа K от 1 до 99 напечатать фразу: "Мне K лет, учитывая, что может быть год, лет, года.
Год: 1, 21, 31, 41... (n mod 10=1).
Лет: 5-20, 25-30, 35-40, 45-50... (n mod 10=0, 5, 6, 7, 8, 9).
Года: 2, 3, 4, 22-24, 32-34, 42-44... (n mod 10=2, 3, 4).

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать

сумму двух других,иначе треугольник не существует. Задача на тему "Программирование ветвлений на Паскале".

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)



Вы находитесь на странице вопроса "ребят!помогите с задачей на Паскаль: Определить, является ли билет счастливым", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.