Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

5-9 класс

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

Ivanko99 21 авг. 2014 г., 1:01:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tankan
21 авг. 2014 г., 1:36:43 (9 лет назад)

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]<a[i+1] then kol:=kol+1;
if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

Ответить

Другие вопросы из категории

Пользователь работал с каталогом

D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА. Сначала он поднялся на три уровня вверх, потом спустился в каталог ИНФОРМАТИКА. Укажите полный путь для того каталога, в котором оказался пользователь (запишите номер правильного ответа):

1)D:\ДОКУМЕНТЫ\ФОТО\ИНФОРМАТИКА\

2)D:\ДОКУМЕНТЫ\ИНФОРМАТИКА\ЭКЗАМЕН

3)D:\ДОКУМЕНТЫ\ЭКЗАМЕН\ИНФОРМАТИКА

4)D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА\ЭКЗАМЕН\ИНФОРМАТИКА

В таблице приведено расписание уроков на один учебный день для учеников 7 класса

Соответствует ли это расписание состоянию работоспособности школьников? Как его можно улучшить с учетом изменения работоспособности школьников (график из предыдущего задания)? Предложите свой вариант.

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

ПОМОГИТЕ ПОЖАЛУЙСТА, ЗАДАЧА ОЧЕНЬ ПРОСТАЯ!!!

Написать программу, которая в последовательности натуральных чисел определяет сумму чисел оканчивающихся на 3. Программа на вход получает сначала кол-во чисел в последовательности, а затем сами числа. Кол-во чисел не превышает 100, а введенные числа не превышают 300.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).



Вы находитесь на странице вопроса "Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.