Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти количество элементов массива значения которых больше заданного числа В и кратно 5. Составить в программе Pasсal ABC.

5-9 класс

17623554kirill 19 марта 2015 г., 6:20:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polinaklubhuka
19 марта 2015 г., 7:30:10 (9 лет назад)

Решать надо примерно так:

Создать массив целых чисел(к примеру на 20 элементов)

Объявить две переменные(счётчик и B)

Написать пользователю чтобы он ввёл значение для B

Заполнить массив числами через цикл for и генератор псевдо-слуайных чисел(к примеру от 0 до 50)

Всё в том же цикле сделать условие типа "если a[i] > B и если a[i] % 5 == 0(делится на 5 без остатка)", то увеличить счётчик на единицу, и после этого условия вывести значение элемента в строчку через пробел

Ну и в конце вывести значение счётчика.

В паскале не разбираюсь, поэтому вот пример решения на C++

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
   int a[20], counter = 0, b;
   srand(time(0));

   cout << "Enter B: ";
   cin >> b;

   for(int i = 0; i < 20; i++)
   {
      a[i] = rand() % 51;

      if(a[i] > b && a[i] % 5 == 0)
      {
         counter++;
      }

      cout << a[i] << ' ';
   }

   cout << "\n" << counter << " numbers" << endl;

   cin.get();
   return 0;
}

Ответить

Другие вопросы из категории

Определить, счастливый ли билетик.

С помощью 2 массивов. Принцип такой: на билете 6 цифр. Если сумма первых трех будет равна сумме следующих трех, то билет-счастливый.

1.А&(BvA)

2.(AиВ) или не А

Используя генератор случайных чисел, заполнить массив размерностью 10 элементов числами из интервала [-20,+20]. Вывести список элементов массива в одну

строку с интервалом 4 пункта.

Ребят, помогите, пожалуйста, вообще не понимаю как делать)
наугад ввела кол-во баллов, не знаю , что они значат

Читайте также

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

1).найти все четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

1).найти все симметричные четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

1.Дан массив

1 2 3 4 5 6 7 8
7 0 -8 -4 2 16 -10 2

А
Определите:
А) размерность массива;
Б) значение элемента А[3];
В) значение максимального элемента массива;
Г) индекс первого отрицательного элемента массива;
Д) индекс элемента, значение которого равно -4;
Е) Значение минимального элемента массива;
Ж) количество элементов массива, значения которых равно 2.

2.Привести пример отрицательного элемента массива с четным индексом.
3.Найти значение переменной Р.
p:=1;
For i:=3 to 5 do
p:=p*(2*i);
write(p);
4.
i:=2; s:=0;
while i<=8 do
begin
s:=s+s/2;
i:=i+2;
end;
write(s);



Вы находитесь на странице вопроса "Найти количество элементов массива значения которых больше заданного числа В и кратно 5. Составить в программе Pasсal ABC.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.