Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найдите пожалуйста max среди элементов главной диагонали.

5-9 класс

ОсОбАя1ЗаЙкА 19 марта 2017 г., 7:24:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andrew789
19 марта 2017 г., 8:10:31 (7 лет назад)

#include <iostream>
#include <ctime>
#include <cstdlib>
#include <iomanip>

const int size = 4;

int main()
{
    int a[size][size];
    srand (time(0));
    for (int i=0; i<size; i++)
    {
        for (int j=0; j<size; j++)
        {
            a[i][j]=rand()%19+1;
            std::cout <<std::setw(3) <<a[i][j];
       }
       std::cout <<std::endl;
    }
    int max = 0;
    for (int i=0; i<size; i++)
        if (a[i][i]>max)
            max = a[i][i];
    std::cout <<"Max: " <<max <<'\n';
    return 0;
}

Ответить

Другие вопросы из категории

Case 12. Элементы окружности пронумерованы следующим образом: 1-радиус, 2-диаметр D=2*R, 3-длина L= 2*pi*R, 4-площадь круга S= pi*R2. Дан

номер одного из этих элементов и его значение. Вывести значение остальных элементов данной окружности (в том же порядке). В качестве значения pi использовать 3,14.


Нужно эту задачу решить в ПАСКАЛЕ.

составить програмку на языке паскаль)

вывести на экран те элементы массива которые делятся на пять без остатка

Читайте также

В двумерном массиве Z[1..5,1..5] найти наименьший элемент среди элементов вспомогательной диагонали. вывести на экран его индексы и значение.

Пожалуйста, не используйте заумных проограмм, составьте её для Паскаля на уровне 9 класса. Большое спасибо.

Последняя задача...если вы мне поможете,то в аттестате 4 будет....пожалуйста помогите.вот:Сформируйте массив содержащий 15 элементов,с помощью датчика

случайных чисел.Получите новый массив,каждый элемент которого равен удвоенному соответствующему элементу исходного массива.В полученном массиве найдите максимальный элемент среди элементов,номера которых кратны трем.Выведите на экран исходные и полученные результаты



Вы находитесь на странице вопроса "Найдите пожалуйста max среди элементов главной диагонали.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.