Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1) Какие сведения могут получить,наблюдая такое явление как "радуга" художник,физик и мальчик? 2) Составить собственную информационную модель

10-11 класс

этого явления

Remover23 16 сент. 2013 г., 19:58:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
3549
16 сент. 2013 г., 20:44:52 (10 лет назад)

Художник - цветовую палитру.

Физик -преломление света, луч света содержит в себе все цвета, и пр.

Мальчик -  О_о

 

 

Ответить

Другие вопросы из категории

Читайте также

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

7) Какое минимальное количество бит потребуется для кодирования положительных чисел, меньших 60? 1) 1 2) 6 3) 36 4) 60

8) Двое играют в «крестики-нолики» на поле 4 на 4 клетки. Какое количество информации получил второй игрок, узнав ход первого игрока?

1) 1 бит 2) 2 бита 3) 4 бита 4) 16 бит

9) Объем сообщения – 7,5 Кбайт. Известно, что данное сообщение содержит 7680 символов. Какова мощность алфавита?

1) 77 2) 256 3) 156 4) 512

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1.Вычисляются два числа

- сумма первых трёх цифр и сумма последних трёх цифр.2.Полученные два числа записываются друг за другом в порядке не убывания (без разделителей).Пример.Исходное число:15177.Поразрядные суммы: 7 ,15.Результат: 715.Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата.2626 2618 2624 2628 2826 2426 1826 610.В ответ запишите только количество чисел ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!



Вы находитесь на странице вопроса "1) Какие сведения могут получить,наблюдая такое явление как "радуга" художник,физик и мальчик? 2) Составить собственную информационную модель", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.