Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

10-11 класс

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.

Alinaaaeee96 03 дек. 2014 г., 21:40:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
EheXed
03 дек. 2014 г., 23:18:46 (9 лет назад)

Готово............................

Ответить

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Написать программу для паскаля. Дана квадратная матрица

порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка



Вы находитесь на странице вопроса "Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.