Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

10-11 класс

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Umrryaevrinat2 01 апр. 2015 г., 15:40:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetabelii99
01 апр. 2015 г., 16:17:15 (9 лет назад)

1)const nmax=50;       mmax=50; var x:array [1..nmax, 1..mmax] of integer; n,m,i,j,ki: integer;   begin   write('Введите размерность матрицы: ');   readln(n,m);   writeln('Введите элементы матрицы: ');   for i:=1 to n do     for j:=1 to m do       readln(x[i,j]);   writeln('Матрица: ');   for i:=1 to n do   begin     for j:=1 to m do       write(x[i,j]);     writeln(' ');   end;     j:=1;   while (j<=m) do   begin     ki:=0;       for i:=1 to n do       if (x[i,j] mod 2 =0) then ki:=ki+1;     writeln('В столбце',j,': ',ki,' чётных элементов');     j:=j+2;   end; end.
2)

+ 0 -
S35255406571655
01 апр. 2015 г., 18:52:59 (9 лет назад)

язык?

Ответить

Другие вопросы из категории

нужно написать программу на языке паскаль по условию:

Найти сумму элементов массива расположенных до последнего положительного элемента
Буду бескрайне благодарна, если поможете мне))

Всем привет. Помогите, пожалуйста, разобраться с этой задачей. Как ее решить в Pascal.

"Вычислить сумму элементов строки, проходящей через первый нулевой элемент побочной диагонали матрицы Q(30,30)."

составить блок схему и программу
В исходной строке а$

определить и вывести слова, в которых первая буква встречается всего один раз.(Бэйсик)

Читайте также

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.

1) Найти сумму четных элементов массива F(12), значения которых больше 2. Вывести также число таких элементов, массив расположен в ячейках D2:D14 листа

Сумма.
Массив: -7 0 3 1 -8 -3 5 3 12 15 40 7

2) Определить в Exel адрес первого числа больше 2.



Вы находитесь на странице вопроса "1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.