Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

заполнить массив из 9 элементов случайными числами в интервале [-10;10] и найти max и min элемент массива и поменять их местами.

10-11 класс

Astra98 12 марта 2015 г., 19:40:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lukashina83
12 марта 2015 г., 20:22:21 (9 лет назад)

var
  mas: array[1..9] of integer;
  max, min, i, j, k, n: integer;
begin
  writeln('Массив до перестановки');
  for i := 1 to 9 do
  begin
    mas[i] := random(11) - random(11);
    write(mas[i], ' ');
  end;
  writeln;
  max := mas[1];
  min := mas[1];
  k := 1;
  j := 1;
  for i := 1 to 9 do
  begin
    if mas[i] > max then
    begin
      max := mas[i];
      j := i;
    end;
    if mas[i] < min then
     begin
      min := mas[i];
      k := i;
    end;
  end;
  n := mas[j];
  mas[j] := min;
  mas[k] := n;
  writeln('Масств после перестановки');
  for i := 1 to 9 do
    write(mas[i], ' ');
end.

+ 0 -
Lyudmilaangelch
12 марта 2015 г., 22:24:55 (9 лет назад)

язык?

+ 0 -
Demon22226
13 марта 2015 г., 0:16:41 (9 лет назад)

паскаль

Ответить

Другие вопросы из категории

построить в Excel построить в Excel
помогите пожалуйста:

Создать массив случайных чисел (1-10), ввести с клавиатуры некоторое значение и определить номер элемента, равна этому значению, если таких элементов не существует, то вывести не существует.

Сколько существует различных наборов значений логических переменныхx1, x2, x3, x4, y1, y2 y3, y4, которые удовлетворяют всем перечисленным

нижеусловиям?(x1 → x2) /\ (x2 → x3) /\ (x3 → x4) = 1(¬y1 \/ y2) /\ (¬y2 \/ y3) /\ (¬y3 \/ y4) = 1(y1 → x1) /\ (y2 → x2) /\ (y3 → x3) /\ (y4 → x4) = 1

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.

Читайте также

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

Срочно! Помогите пожалуста! Нужно написать програмный код в турбо паскале! Заранее ОГРОМНОЕ СПАСИБО!! Заполнить массив из 10 элементов

случайными числами в интервале от 0 до 4 и вывести номера всех элементов, равных X.

Пример:

Исходный массив:

4 0 1 2 0 1 3 4 1 0

Что ищем? 0

A[2], A[5], A[10]

Срочно! Помогите! Написать программу в турбо паскале Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить,

есть ли в нем одинаковые соседние элементы.

Пример:

Исходный массив:

4 0 1 2 0 1 3 1 1 0

Заранее огромное спасибо!!!!

Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре. Пример: Исходный

массив:

14 25 13 30 76 58 32 11 41 97

Результат:

30 11 41 32 13 14 25 76 97 58

говорили про какой-то метод пузырька. хелп ми Т_т

p.s. паскаль abc

ребят ,если честно - срочно...



Вы находитесь на странице вопроса "заполнить массив из 9 элементов случайными числами в интервале [-10;10] и найти max и min элемент массива и поменять их местами.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.