Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ. НАЙТИ НАИБОЛЬШИЙ ОБЩИЙ ДЕЛИТЕЛЬ 2 НАТУРАЛЬНЫХ ЧИСЕЛ!

1-4 класс

Denismandych 31 мая 2014 г., 5:17:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Clare
31 мая 2014 г., 7:58:33 (9 лет назад)

program prim; uses crt; var x,y:integer; begin writeln ('введите x,y'); readln (x,y); while x<>y do begin if x>y then x:=x-y else y:=y-x end; write ('НОД=',x); end.

+ 0 -
Funtik456
31 мая 2014 г., 9:55:56 (9 лет назад)

var a,c,b:integer;
begin
readln(a,b);
while b>0 do begin
a:=a mod b;
c:=a;a:=b;b:=c;
end;
writeln(a);
end.

Ответить

Другие вопросы из категории

В следующих примерах укажите информационный носитель и форму представления информации:

Носитель
Пример
Форма представления
Бумага
Письмо от друга
Текстовая информация

Табличка с номером дома


Билет на самолет


Газета


Кинофильм

даю 100 балов

Читайте также

Найти максимальный элемент массива X(10).

помогите написать программу в паскале пожалуйста.

Даны числа: x, y. Вычислите: z=x+y, если

x \leq y, и z=x-y в противном случае.

Написать программу в паскале.

Даны действительные числа x,y,z Если все числа положительны, увеличить их значения в 2 раза;во всех отальных случаях отрицательные числа заменить их

модулями, а положительные оставить без изменения.(Надо написать программу на паскале)



Вы находитесь на странице вопроса "НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ. НАЙТИ НАИБОЛЬШИЙ ОБЩИЙ ДЕЛИТЕЛЬ 2 НАТУРАЛЬНЫХ ЧИСЕЛ!", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.