Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу,которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце.Рассмотреть два случая: 1.год

10-11 класс

високосный.
2.год не является високосным

Alyona8564 20 авг. 2014 г., 11:37:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rmuhametov1004
20 авг. 2014 г., 13:16:29 (9 лет назад)

Program G;
Uses Crt;
Var count, num, ch: integer;
Begin 
 ClrScr; 
 Writeln('Год високосный? 1 - да, 0 - нет'); 
 Readln(Ch); 
 If ch=1 then 
  Begin   
   Writeln('Введите номер месяца'); 
   Readln(num);   
   Сase num of  
    1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.'); 
    4, 6, 9, 11: writeln('В месяце 30 дней.'); 
    2: writeln('В месяце 29 дней');   
   else writeln('Некорректный ввод данных')   
  End; 
 End  
 Else if ch=0  then 
  Begin   
   Writeln('Введите номер месяца');    
   Readln(num);
   Сase num of    
    1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');   
    4, 6, 9, 11: writeln('В месяце 30 дней.');   
    2: writeln('В месяце 28 дней');   
   else writeln('Некорректный ввод данных')   
   End; 
  End 
 Else writeln('Некорректный ввод данных');
Readln; 
End.

Ответить

Другие вопросы из категории

ввести число.если оно положительное,уменьшить его на 3,пока оно не станет отрицательным.Если же число отрицательное,то увеличивать его на 2,пока оно не

станет больше 70.Ни экраны вевести оба число.

ЗАПИСАТЬ ЗАДАЧУ В ПАСКАЛЕ!И ЕСЛИ МОЖНО ПРАВИЛЬНУЮ БЛОК СХЕМУ!

8. Запишите имя файла, для которого

выполнились бы все перечисленные ниже условия:

В чем преимущество компьютерных информационных моделей перед теоретическими?

Вопрос из учебника информатики за 10 класс, автор Семакин, §13 "Компьютерное информационное моделирование"

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Составьте программу с использованием условного оператора, предусмотрите вариант, когда значение будет выходить за пределы диапазона, в этом случае

экран должен очищаться , выводиться подсказка и программа должна возвращаться в начало. Условие для программы: Cоставьте программу , которая в зависимости от азимута, показываемого стрелкой компаса, определят страны света: север юг, воcток,запад.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0



Вы находитесь на странице вопроса "составить программу,которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце.Рассмотреть два случая: 1.год", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.