Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ввести число.если оно положительное,уменьшить его на 3,пока оно не станет отрицательным.Если же число отрицательное,то увеличивать его на 2,пока оно не

10-11 класс

станет больше 70.Ни экраны вевести оба число.

ЗАПИСАТЬ ЗАДАЧУ В ПАСКАЛЕ!И ЕСЛИ МОЖНО ПРАВИЛЬНУЮ БЛОК СХЕМУ!

Kseniarom94 07 авг. 2014 г., 18:11:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Guz218
07 авг. 2014 г., 20:52:25 (9 лет назад)

var a:integer;
begin
readln (a);
if (a>0) then
repeat
a:=a-3;
until(a<0);

 

if (b<0) then
repeat
a:=a+2;
until (a>70);

writeln (a);
end.

Ответить

Другие вопросы из категории

8. Запишите имя файла, для которого

выполнились бы все перечисленные ниже условия:

В чем преимущество компьютерных информационных моделей перед теоретическими?

Вопрос из учебника информатики за 10 класс, автор Семакин, §13 "Компьютерное информационное моделирование"

Program z;

var
s:real;
i,x,n:integer;
begin
writeln('ввод x,n');
readln(x,n);
for i:=n to 1 do
s:=s*(((-1)*exp(i+1)*ln(1))/exp(i+ln(2*x+1)));
writeln('ответ s=',s);
end.

По какой причине S ,независимо то значений X и N, получается равным нулю?

Читайте также

Не сложно, но срочно.

Написать программу для Pascal.
Дано целое число, если оно является положительным, то прибавь к нему 5; в противном случае не изменять его. Вывести полученное число.



Вы находитесь на странице вопроса "ввести число.если оно положительное,уменьшить его на 3,пока оно не станет отрицательным.Если же число отрицательное,то увеличивать его на 2,пока оно не", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.