Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Program z;

10-11 класс

var
s:real;
i,x,n:integer;
begin
writeln('ввод x,n');
readln(x,n);
for i:=n to 1 do
s:=s*(((-1)*exp(i+1)*ln(1))/exp(i+ln(2*x+1)));
writeln('ответ s=',s);
end.

По какой причине S ,независимо то значений X и N, получается равным нулю?

огреб 01 июня 2014 г., 13:37:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ELZZA
01 июня 2014 г., 14:20:46 (9 лет назад)

Так у тебя же S не вводиться с клавиатуры. Как тебе уже писали в ячейке памяти где находиться переменная S по-умолчанию имеется какое-то значение. Не обязательно это должен быть 0. Сделай следуйщее:
- задай значение переменной S=1; По скольку первое значение S в примере не будет равен 0. Но если ты будешь делать какой-то цикл, то значение S ,будет каждый раз меняться и не будет равно 0. 

+ 0 -
Anastasiaborlo
01 июня 2014 г., 15:30:01 (9 лет назад)

изначально в переменных находится либо мусор, либо 0 => s:=s*(((-1)... происходит s:=0*(((-1)... =0

Ответить

Другие вопросы из категории

Составить легкую программу!

Зеркально отразить последовательность в одномерном массиве.

Т.е. Задаем последовательность, вводим границы "зеркала" - х и у. И зеркально отражаем.
Пример:12345678910
х=5

у=8

Вывод:12348765910.
Очень буду блгодарна!

Срочно! Есть возможность заработать 50 баллов!!!!!!!!!!!!!!!!!

Составить таблицу истинности для выражения

Читайте также

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

Какая тут ошибка, посмотрите, пожалуйста program znacheniya uglov; uses crt; var x: integer; begin writeln('wedite znachenie gradusnoi mery ugla');

read(x); if a=180 then writeln('razvernutyi') else writeln ('ne razvernutyi'); end.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

program vst; var

c:



Вы находитесь на странице вопроса "Program z;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.