Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите составить быстрее и правильно пожалуйста массиве А(20),заполненном случайными числами в диапазоне (-50:+50) поменять

5-9 класс

местами наибольше элемент с наименьшим.Распечатать полученный

физик2012 04 марта 2015 г., 14:30:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЛемуркаТаня
04 марта 2015 г., 16:09:08 (9 лет назад)

var a:array[1..20] of integer;
min,max,i:integer;
begin
min:=1;
max:=1;
for i:=1 to 20 do begin
a[i]:=random(-50,50);
if a[i]>a[max] then max:=i;
if a[i]<a[min] then min:=i;
end;
i:=a[min];
a[min]:=a[max];
a[max]:=i;
for i:=1 to 20 do
write(a[i],' ');
end.

Ответить

Другие вопросы из категории

составить программу для вычисления суммы квадратов чисел от 1 до 15. Функция возведения в квадрат sqr();

Var , , : ;
Begin
:=0;
For := to do
Begin
;
;
End;
Writeln(' =', );
End.
Там, где пробелы, вставить что нужно

Дан массив вещественных чисел. Вывести на экран новое состояние массива ,

в котором все элементы с нечётными номерами заменить на их квадратный корень.

На одной улице стоят в ряд 4 дома, в каждом из них живет по одному человеку. Их зовут Маша, Даша, Глаша и Наташа. Известно, что все они имеют разные

профессии: ткачиха, портниха, швея, повариха. Определите профессию Даши, если известно, что: a) ткачиха живет с краю; b) портниха живет правее швеи; c) повариха живет левее швеи; d) ткачиха живет рядом с поварихой; e) Маша живет через дом от Наташи; f) Глаша не ткачиха и не живет рядом с ткачихой; g) Наташа живет рядом со швеёй; h) Маша живет правее поварихи.

помогите пожалуйста.

a) C:= sqr(35 div (18mod 5))+ frac (19/2)
d) N:= trunc(sqrt(144))-15 mod 4*5-15 div 4*2+0.5

Читайте также

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте программу заполнения массива A(20) датчиком случайных чисел в диапазоне от -50 до 49 включительно.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Помогите составить быстрее и правильно пожалуйста массиве А(20),заполненном случайными числами в диапазоне (-50:+50) поменять", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.