Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Используя циклы решить задачу в паскале: Вычислить значение переменной у, при заданном значении n

10-11 класс

Shcherbin1957 09 авг. 2015 г., 15:55:24 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
A22
09 авг. 2015 г., 18:34:27 (8 лет назад)

Var
   y: real;
   x,n: integer;
Begin
   Writeln('n=');
   Readln(n);
   y:=0;
   x:=0;
        For x:=0 to n do
            begin
                y:=y+x/(x+2);
            end;
   Writeln(y:6:5);
end.

+ 0 -
Dredd1603
09 авг. 2015 г., 19:05:42 (8 лет назад)

Пользователь Josy всё верно написал. Цикл заключается в том, что пошагово вместо числа n ты подставляешь любые числа (в данном случае натуральные). Получая для каждого n собственное y. Решая в Паскале, компьютер запросит тебя ввести любое число и вычислит Y. Удачи!

Ответить

Другие вопросы из категории

Для кодирования цвета фона страницы Интернет используется атрибут bgcolor="ХХХХХХ", где в кавычках задаются шестнадцатеричные значения

интенсивности цветовых компонент в 24-битной RGB-модели следующим образом:

Какой цвет будет у страницы, заданной тэгом <body bgcolor="818181">?

Черно-белое (без градаций серого) графическое изображение имеет размер 10*10.

Какой объем памяти займет это изображение?

ПОМОГИТЕ!

Задать три строки string
1) найти самую длинную, найти среднюю и наимешьную
2) Склеить среднюю и наименьшую и вывести их
3) Склеить все три и вывести их
Буду безумно благодарна, ребята!

Читайте также

Даны величины переменных A,B,C,D. Требуется перенести значения переменных, следующим образом: в D сумму значений переменных С и В, в переменную А

поместить значение из В, в В значение из С, в С значение из D решение в паскале

Помогите решить

Вычислить значение логического выражения L при заданных значениях переменных
L=(not(A=1)) and ((a=b) or (a<0)), при A=0, B=1

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.




Вы находитесь на странице вопроса "Используя циклы решить задачу в паскале: Вычислить значение переменной у, при заданном значении n", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.