Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В программе турбопаскаль

10-11 класс

Задана квадратная матрица. Переставить строку с максимальным
элементом на главной диагонали со строкой с заданным номером (номер
строки вводится в начале программы)
должно быть:
Описание алгоритма решения задания
Описание переменных и подпрограмм.
Текст программы
Результаты работы программы

Aleksamrrr 08 июня 2016 г., 15:40:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PabloChakone
08 июня 2016 г., 17:08:17 (7 лет назад)

Надеюсь расписал подробно.

+ 0 -
Wyvu
08 июня 2016 г., 17:58:47 (7 лет назад)

погоди чуть-чуть, щас напишу

+ 0 -
Arty120000
08 июня 2016 г., 20:56:27 (7 лет назад)

хорошо, я буду ждать)))

+ 0 -
Aznaika
08 июня 2016 г., 21:59:21 (7 лет назад)

надо за компьютер сесть, я с телефона долго писать буду

+ 0 -
Sik1755
09 июня 2016 г., 0:46:43 (7 лет назад)

хорошо, я жду

+ 0 -
Marinakiparis20
09 июня 2016 г., 3:05:16 (7 лет назад)

вы поможете мне? пожалуйста

Ответить

Другие вопросы из категории

Одномерный

массив из 8 элементов заполнить случайным образом числами от 10 до 20. Заменить все элементы массива меньшие 15 их
удвоенными значениями. Вывести на экран монитора первоначальный и
преобразованный массивы в столбик
(столбики должны быть расположены рядом).

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Вам необходимо преобразовать множество старых программ для новой версии компилятора. Для этого необходимо заменить "->" на "." везде, кроме

комментариев. Комментарии в данном языке программирования начинаются с символов "//" и продолжаются до конца строки. Напишите программу, выполняющую такое преобразование. Входной файл содержит от 1 до 500 строк длиной не более 50 символов с ASCII-кодами от 32 до 127 – текст программы, которую нужно преобразовать. В выходной файл вывести преобразованный текст программы.

Пример ввода

Test* t = new Test(); t->a = 1; t->b = 2; t->go(); // a=1, b=2 -> a=2, b=3

Вывод для примера

Test* t = new Test(); t.a = 1; t.b = 2; t.go(); // a=1, b=2 -> a=2, b=3

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?



Вы находитесь на странице вопроса "В программе турбопаскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.