Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать

5-9 класс

цикл с предусловием while <условие> do. Информатика. 8 класс. Паскаль ABC.

НиЧёНИЗНАЮ 10 мая 2013 г., 13:38:42 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Davtyanrob15
10 мая 2013 г., 14:35:37 (11 лет назад)

var n:integer;var b:array[0..9] of boolean;var f:boolean;begin     f := false;     readln(n);     while n > 0 do           begin                if b[n mod 10] then                   begin f := true; break; end                else b[n mod 10] := true;                n := n div 10;           end;     if f then writeln('da') else writeln('net');end.

Ответить

Другие вопросы из категории

1)Если маска подсети

255.255.224.0
и IP-адрес компьютера в сети 206.158.124.67,
то номер компьютера в сети равен:

Читайте также

Задачка в Pascal: ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры. (Циклы с условием) Решение

должно быть простым, потому что такие вещи, как массивы ещё не прошли. Скорее всего здесь будет использоваться while, div, mod.

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

Ввести

целое число и определить, верно ли, что в нём ровно 1 цифра
«9». (Кумир)

Напишите программу в Паскаль для решения задачи:

Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10



Вы находитесь на странице вопроса "Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.