Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести

5-9 класс

целое число и определить, верно ли, что в нём ровно 1 цифра
«9». (Кумир)

Ales342 12 апр. 2015 г., 13:41:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Victoriazel76
12 апр. 2015 г., 16:07:02 (9 лет назад)

Берешь какое-нибудь число делишь его на девять, и узнаешь сколько в числе цифр 9, например 10:9=1(1ост.)

+ 0 -
вгноаи
12 апр. 2015 г., 18:11:14 (9 лет назад)

var
x,i: integer;
s: string;
begin
write('Введите число: ');
readln(s);
for i:= 1 to length(s) do if s[i] = '9' then inc(x);
write(x);
end

+ 0 -
Аминка37
12 апр. 2015 г., 19:25:18 (9 лет назад)

(Кумир)

Ответить

Другие вопросы из категории

ребят помогите нада написатьребят помогите нада написать програму в паскале через оператор for

напишіть програму обчислення добутків
a(a+1)(a+2)...(a+n+1)

1) Известны длины сторон треугольника a,b,c. Напишите программу, вычисляющую площадь этого треугольника.

2) Если сумма налога исчисляется в рублях и копейках, то налоговая служба округляет ее до ближайшего рубля (до 50 копеек - с недостатком, свыше 50 копеек (включая 50) - с избытком). Используйте компьютер, чтобы ввести точную сумму налога и вывести, сколько следует уплатить.

решение задачи в паскале: дано предложение, все пробелы в нём заменить на *, а остальное заменить на -

Нужно менять саму строку, а не просто символы выводить

Читайте также

На вход программы, приведенной ниже, поданы два числа: 1 и 3. Ввести x и y; x=y-x y=2*x x=2*y+x y=y+x/2

Ввести x и y

Какие значения будут выведены в результате ее работы?

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)

1)В поезде 17 вагонов, 10-17-купейные, остальные-плацкарт.Ввести № вагона.напечатать вид.

2)Ввести 2 числа. Напечатать их частное или сообщить, что на 0 делить нельзя

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).



Вы находитесь на странице вопроса "Ввести", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.