Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе.С использованием case. Массивы не проходили.

5-9 класс

Cnfkmyjqrekfr 10 янв. 2015 г., 4:22:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
A831396
10 янв. 2015 г., 7:18:13 (9 лет назад)

Не совсем понятно, что значит число ошибок при вводе?
Могу предложить такой вариант решения:
program Dni;
var
m:integer;
Begin
writeln('Введите номер месяца');
readln(m);
case m of 
1,3,5,7,8,10,12:writeln('31 день');
2:writeln('В високосном году в феврале 29 дне, в обычном году - 28 дней');
4,6,9,11:writeln('30 дней');
else writeln('В году 12 месяцев. Вы ввели ошибочный номер');
END.

Ответить

Другие вопросы из категории

нужно написать программу в ПАСКАЛЕ

Описать функцию Quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). С помощью этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

Читайте также

Структурные операторы в языке pascal: Развилка и выбор.

1.Даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями.
2.Составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

Составить прогрмму в паскале-кейс.

которая по заданному году и номеру месяца m определяет оличество дней в этом месяце



Вы находитесь на странице вопроса "Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе.С использованием case. Массивы не проходили.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.