Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Структурные операторы в языке pascal: Развилка и выбор.

5-9 класс

1.Даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями.
2.Составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

настёнаViP 18 сент. 2013 г., 5:25:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bislan01
18 сент. 2013 г., 6:47:38 (10 лет назад)

первая прога:
program pr1;
uses crt
var m,n:real;
begin
clrscr;
writeln('insert the numbers');
readln(m, n);
if m <> n then begin
if m > n then begin
n:=m;
end
else begin
m:=n;
writeln(m,n);
end;
end
else begin 
m:=0;
n:=0;
writeln(m,n);
end;
end.

Вторая прога:
program pr2;
ues crt
var y,m,d,k: integer;
begin
clrscr;
writeln('insert the year);
readln(y);
writeln('insert the month');
readln(m);
if m > 12 then begin
writeln('error');
end;
if m mod 2 <> 0  then begin
d:= 31;
end;
if m=2 then begin
d:= 28;
end;
if m mod 2 = 0 then begin
d:=30;
end;
writeln('the number of the days in your month:');
writeln(d);
end.

Ответить

Другие вопросы из категории

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык
Бейсик
Паскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s+11

кц

вывод s

кон


DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

s = s+11

NEXT k

PRINT s
Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s+11;

writeln(s);

End.

1.Составьте программу заполнения массива НЕ ИСПОЛЬЗУЯ КЛАВИАТУРУ числами -2, 4,-6,8,-10...20.

2.Сформировать одномерный массив из 30 элементов (задаются ГСЧ-рандомно) из интервала -3..3. Массив вывести.Найти номер положительных элементов и их сумму чисел.

Читайте также

оператор WRITE на языке Pascal означает:

1.ввод с клавиатуры значение переменой
2.вывод на экран информации
3.присваивание переменной значения

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal

Написать выражения на языке Pascal
Ребят задача на языке Pascal...

Дано целое число, если оно двузначное, то умножить на 2, в противном случае вычесть 10.



Вы находитесь на странице вопроса "Структурные операторы в языке pascal: Развилка и выбор.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.