Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать программу, вычисляющую среднее арифметическое последовательности положительных чисел

5-9 класс

Masjandrikovna 22 сент. 2014 г., 13:14:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vedenyowalidia
22 сент. 2014 г., 15:45:42 (9 лет назад)

program qq;
var b,c,i,n,e: integer;
a:real;
begin;
b:= 0;
readln ( c,n);
for i:= c to n do
begin
b:= b+i;
end;
e:= (n-c) +1;
a:= b/e;
writeln (a);
end.

n и c это начало и конец промежутка ( например от 5 до 7)

+ 0 -
МарияМаксимова
22 сент. 2014 г., 17:38:19 (9 лет назад)

последовательность ввоидтся с клавиатуры или есть какойто промежуток?

+ 0 -
Nikishin2002
22 сент. 2014 г., 18:55:20 (9 лет назад)

вывод на экран

Ответить

Другие вопросы из категории

Задание 1. Чему равен F(x) после выполнения следующих операторов? для x=4; 5; 3; 2; if x>=3

then if x<5 then F:=0

else F:=x*x

else F:=4+x

Чему равен R после выполнения следующих операторов?

R:= -10; 0; 5

if R<0 then R:=R*R;

if R=0 then R:=R+10;

if R>0 then R:=R-100;

Какие бывают интерфейсы

Читайте также

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.



Вы находитесь на странице вопроса "написать программу, вычисляющую среднее арифметическое последовательности положительных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.