Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Записать на языке «Паскаль»

10-11 класс

программу, реализующую алгоритм работы кассира, выдающего покупателю сдачу
сумма «S» наименьшим кол-вом банкнот по 1000 , 500, 100, 50, 10 рублей.

Срочно, помогите!

Дианkа1999 26 февр. 2015 г., 1:54:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дмитрий1Kotov
26 февр. 2015 г., 2:40:54 (9 лет назад)

var
  s: longint;
  n: array[1..5] of integer;
  c, i: integer;

begin
  n[1] := 1000;
  n[2] := 500;
  n[3] := 100;
  n[4] := 50;
  n[5] := 10;
  Write('Введите сумму, кратную 10: ');
  Readln(s);
  if (s mod 10) <> 0 then s := 10 * (s div 10);
  i := 1;
  while s > 0 do
  begin
    c := s div n[i];
    if c > 0 then begin Write(n[i], 'x', c, ' '); s := s mod n[i] end;
    i := i + 1
  end
end.

Тестовое решение:

Введите сумму, кратную 10: 52380
1000x52 100x3 50x1 10x3


+ 0 -
Sheldoon
26 февр. 2015 г., 4:25:52 (9 лет назад)

а если сдача 5 руб 20 коп?

+ 0 -
Lusic
26 февр. 2015 г., 5:56:07 (9 лет назад)

или хотя бы 25 руб?

+ 0 -
Olyabragina2001
26 февр. 2015 г., 8:35:02 (9 лет назад)

Попробуйте получить её в банкомате. Так и тут.

+ 0 -
Mariashell
26 февр. 2015 г., 11:33:33 (9 лет назад)

)))

Ответить

Другие вопросы из категории

С клавиатуры вводятся два числа x и y.

Найти разновидность z между большим и меньшим из них

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

1)Напишите,какой записи на языке Паскаль соответствует словестное выражение а)переменную d

увеличить на 5;

б)переменную b уменьшить на 2;

в)переменной d присвоить b;

2)Чему равен результат вычесления арифметического выражения,если известно,что a=3;b=9;c=-10

a)abs(a+d)-1=...

b)trunc(a*b*/c)+frac(b*2/c)=...

какая ошибка в записи на языке паскаль?

x=0 and y<>8



Вы находитесь на странице вопроса "Записать на языке «Паскаль»", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.