Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от -2 до 10. Размерность массива произвольная.

5-9 класс

ИЛИ Дан массив, содержащий 12 элементов и заполненный по формуле A=(i-4)/(3*i). Найти количество элементов в этом массиве больших 0, но меньших 0,2. (решение писать как в турбо паскале)

КасТТер 26 февр. 2015 г., 20:51:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tural000
26 февр. 2015 г., 21:21:49 (9 лет назад)

const

n=10;

var

a:array [1..n] of integer;

i,s,k:integer;

sr:real;

begin

randomize;

s:=0;

k:=0;

for i:=1 to n do begin

a[i]:=random(31)-10;

write (a[i],' ');

if (a[i]>-2) and (a[i]<10) then 

begin

k:=k+1;

s:=s+a[i];

end;

end;

writeln;

sr:=s/k;

writeln (sr:0:2);

readln;

end.

Ответить

Другие вопросы из категории

Задача в программе Паскаль.

Составь программу, которая из слова ИНФОРМАТИКА получит слова: ФОРТ, ТИК, ФОРТ

Устройство оброботки информации 9букв

Устройство ввода графической информации 6букв. Ответе срочно пожалуйста >

Читайте также

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от -2 до 10. Размерность массива произвольная.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.