Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Как найти среднее арифметическое однозначных чисел, введённых с клавиатуры n раз?

10-11 класс

Sozinov111 16 окт. 2014 г., 22:24:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mila1961
16 окт. 2014 г., 23:30:39 (9 лет назад)

сложить эти числа и поделить на n раз

Ответить

Другие вопросы из категории

Упростите логическое выражение: #g*h+g*#h+#g*#h до наиболее краткой формы.

(для обозначения инверсии используется знак # перед переменной, например, #h означает h с инверсией, для обозначения логического сложения и умножения используются знаки "+" и "*"

У Васи есть доступ к Интернет по высокоскоростному одностороннему

радиоканалу, обеспечивающему скорость получения им информации У Васи есть доступ к Интернет по высокоскоростному одностороннему
радиоканалу, обеспечивающему скорость получения им информации 217
бит в секунду. У Пети нет скоростного доступа в Интернет, но есть
возможность получать информацию от Васи по низкоскоростному телефонному
каналу со средней скоростью 216 бит в секунду. Петя
договорился с Васей, что тот будет скачивать для него данные объемом 8
Мбайта по высокоскоростному каналу и ретранслировать их Пете по
низкоскоростному каналу. Компьютер Васи может начать ретрансляцию данных
не раньше, чем им будут получены первые 1024 Кбайт этих данных. Каков
минимально возможный промежуток времени (в секундах), с момента начала
скачивания Васей данных, до полного их получения Петей? В ответе укажите
только число, слово «секунд» или букву «с» добавлять не нужно.
бит в секунду.

Cоставить алгоритм и написать программу.

Найдите дискриминант квадратного уравнения:y=5x^2+6x-7

Помогите, пожалуйста, решить задачи в паскале :

1.Определите сколько нечетных чисел среди четырех заданных чисел
2.Вычислите, является ли четырехзначное число счастливым

Читайте также

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.



Вы находитесь на странице вопроса "Как найти среднее арифметическое однозначных чисел, введённых с клавиатуры n раз?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.