Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ребяяяят, помогите пожалуйста. ОЧЕНЬ СРОЧНО НУЖНО!!! Написать программу которая вводит последовательность вещественных чисел, состоящую их N

5-9 класс

элементов, и определяет, является ли эта последовательность возростающей.

DaRk1278 03 нояб. 2016 г., 16:08:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bergenlove
03 нояб. 2016 г., 18:47:55 (7 лет назад)

const nn=100;
var
a:array [1..nn] of real;
i,n,k:integer;
begin
write('N= ');
readln(n);
for i:= 1 to n do readln(a[i]);
i:=1;k:=0;
while (k=0) and (i<n) do
  begin
    if a[i]>a[i+1] then k:=1;
    i:=i+1;
  end;
if k=0 then writeln('Последовательность возрастающая')
        else writeln('Последовательность не возрастающая');
end.

Ответить

Читайте также

Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!

Помогите пожалуйста, очень срочно!

Нужно написать программу,где машина должна будет тебе выдать название месяца, сколько дней в этом месяце и какой это день недели.
Решить нужно в Pascal

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).



Вы находитесь на странице вопроса "Ребяяяят, помогите пожалуйста. ОЧЕНЬ СРОЧНО НУЖНО!!! Написать программу которая вводит последовательность вещественных чисел, состоящую их N", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.