Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

определить есть ли в заштрихованной части массива элемент, равный а ( Первый рисунок)

5-9 класс

джульетта111 15 мая 2013 г., 11:58:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мария2305
15 мая 2013 г., 14:07:16 (10 лет назад)

const
n=5;
var
mas: array [1..n, 1..n] of integer;
i,j, eI, eJ: byte;
a: integer;
poisk: boolean;
begin
poisk:=false;
Randomize;
for i:=1 to n do 
begin 
for j:=1 to n do   
begin   
mas[i, j] := Random(100);   
write(mas[i, j]:5);   
end; 
writeln; 
end;
write('A = ');
readln(a);
for j:=1 to n do 
for i:=n downto j do   
if mas[i, j] = a then     
begin     
eI:=i;     
eJ:=j;     
poisk:=true;     
break;     
end;
if poisk then writeln('YES, mas[', eI, ', ', eJ, '] = a = ', mas[eI, eJ]) 
else writeln('NO');
end.

Ответить

Другие вопросы из категории

Средняя скорость передачи данных по некоторому каналу связи равна 29 Кбит/с. Сколько секунд потребуется для передачи по этому каналу 50 страниц текста,

если считать, что один символ кодируется одним байтом и на каждой странице в среднем 96 символов?

Читайте также

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

HELP!!

*Дан массив А целых чисел, состоящий из 20 элементов. Заполнить с клавиатуры.
1) Создать новый массив В, каждый элемент которого равен корню квадратному элемента массива А.
2)Найти сумму элементов массива с 11 по 15.
3) Найти элемент массива кратный 8 и его индекс.
4)Найти удвоенную сумму положительных элементов.
5)Вывести индексы тех элементов, значения которых больше значения предыдущего элемента( начиная со второго).
6) Определить, есть ли 2 пары соседних элементов с одинаковыми знаками.
7)Найти количество положительных элементов.
8)Вычесть из положительных элементов элемент с номером 2, а к отрицательным прибавить элемент с номером 4.
9) Удалить из таблицы все элементы массива, кратные 3 или 5.
10) Поменять местами второй элемент массива и первый чётный.
Помогите пожалуйста. Срочно нужно)



Вы находитесь на странице вопроса "определить есть ли в заштрихованной части массива элемент, равный а ( Первый рисунок)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.