Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)

10-11 класс

Помогите пожалуйста очень срочно надо))), заранее спасибо)))

BLACKufa102 04 авг. 2013 г., 22:56:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
евгения313
04 авг. 2013 г., 23:40:52 (10 лет назад)

решение данной задачи для n-го кол-ва элементов(если надо 3, то просто присвой n=3) на языке C/C++ :

#include <iostream>
using namespace std;
int main()
{
int n; // обьявление переменной под размер миссива
cin>>n; // или n=3, если тебе надо всего 3 элемента ввести
int mas[n]; // обьявление массива
for(int i=0;i<n;i++)
cin>>mas[i];        // занесение элементов в массив
int sum=0, count=0; // переменная под сумму положительных и их кол-во
for(int i=0;i<n;i++)
{
if(mas[i]>0)
{
sum+=mas[i];
count++;
}
cout<<sum/count; // вывод результата через формулу сумма/кол-во
return 0;
}

Ответить

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.



Вы находитесь на странице вопроса "Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.