Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Имеется кусок ткани длиной M метров. От него последовательно отрезаются куски разной длины. Все данные заносятся на компьютер. Компьютер должен выдать сооб

5-9 класс

щение о том что материала не хватает, если будет затребован кусок ткани, большей длины чем имеется.
НА ПАСКАЛЕ, ПОДАЛУЙСТА

Natab124 26 апр. 2014 г., 8:16:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Prostopricol
26 апр. 2014 г., 9:23:46 (10 лет назад)

var m,b,c,i:integer;
begin
readln (m);
readln (b); // Сколько будет кусков
for i:=1 to b do
begin
readln(c);
m:=m-c;
end;
If m<0 then writeln('Ткани не хватит');
end.

+ 0 -
Elisar2013
26 апр. 2014 г., 10:05:24 (10 лет назад)

Комментарий удален

Ответить

Читайте также

Написать программу в паскале: Имеется кусок ткани длинной M метров. От него последовательно отрезаются куски равной длины. Все данные по использованию

ткани заносятся в компьютер. Компьютер должен выдать сообщение о том, что материала не хватает, если будет затребован кусок ткани больше длины, чем имеется.

Составьте программу в паскале со всеми строчками!!! Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна А метров, а

высота - В метров. Рулон обоев имеет длину 12 метров и ширину K см. Составьте алгоритм и программу, которая определит стоимость обоев для всей стены, если цена одного рулона C руб.

Около стены наклонно стоит лестница Х метров. Один её конец находится на расстоянии Y метров от стены. Определить высоту лестницы над полом для

значений Х=К метров и Y , изменяющегося от 2 до 3 метров с шагом Н метров.

Желательно, чтобы был алгоритм или блок-схема...

Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна А метрам, а высота В метрам. Рулон обоев имеет длину L метров и ширину S

метров. Сколько будут стоить обои для всей стены, сколько потребуется рулонов обоев, если стоимость одного рулона К рублей. Пожалуйста,помогите! Срочно!



Вы находитесь на странице вопроса "Имеется кусок ткани длиной M метров. От него последовательно отрезаются куски разной длины. Все данные заносятся на компьютер. Компьютер должен выдать сооб", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.