Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

разработать схему алгоритма который вводит массив из n целых чисел выволит номера отрицательных элементов и сами эти элементы

10-11 класс

87055961734 11 дек. 2016 г., 14:23:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rom4ik1997
11 дек. 2016 г., 15:23:59 (7 лет назад)

for(i:=1 to n) a[i]:=random(101);// заполняшь массив a целыми числами в диапозоне от 0 до 100

Cхема вывода номера отрицательного элемента и самого этого элемента.

+ 0 -
Koffka
11 дек. 2016 г., 16:57:05 (7 лет назад)

Блок-схема - во вложении.

 

Program Poliklolik;
const n=10;
var a:array[1..n] of integer;
 i: integer;
  begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK!            ***');
  for i:=1 to n do
  begin
    write('Введите ',i,'-e число ');
    readln(a[i]);
  end;
  writeln('отрицательные элементы массива: ');
  for i:=1 to n do
    if a[i]<0 then writeln(i,'-й:  ',a[i]);
  writeln('***        The end          ***');
end.

Ответить

Другие вопросы из категории

Ребят помогите пожалуйста

В4) Все 5-буквенные слова, составленные из букв И, О, У, записаны в алфавитном порядке и пронумерованы.
Вот начало списка:
1. ИИИИИ
2. ИИИИО
3. ИИИИУ
4. ИИИОИ
......
Запишите слово, которое стоит под номером 238.

Читайте также

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

ЛБ- 70 Разработайте алгоритм для вычисления площади треугольника: s = 1/2ah, где а – длина основания треугольника, h – его высота.

ВБ- 71 Разработайте схему алгоритма, который проверяет, не превосходит ли сумма двух действительных чисел А и В числа 100. Если не превосходит, установить значение флага F=0, иначе установить значение флага F=1. Вывести значение F.

ЦА-10 Разработайте схему алгоритма для вычисления суммы S первых n целых чисел. Предусмотрите ввод значения n с клавиатуры. Текущее значение целого числа имеет имя i (i = 1, 2, .., n).



Вы находитесь на странице вопроса "разработать схему алгоритма который вводит массив из n целых чисел выволит номера отрицательных элементов и сами эти элементы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.