Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Для произвольного числа, введенного с клавиатуры, найти сумму цифр кратных двум и меньших восьми

10-11 класс

Шпана 12 дек. 2013 г., 20:34:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexs02
12 дек. 2013 г., 22:18:45 (10 лет назад)

uses crt;
var n,sum,i:integer;
begin
read(n);
while n>0 do
begin
if ((n mod 10) mod 2=0) and (n mod 10<8) then
sum:=sum+(n mod 10);
n:=n div 10;
end;
writeln(sum);
end.

Ответить

Другие вопросы из категории

а)Для кодирования 300 различных сообщений используют 5 последовательных цветовых вспышек .Лампочки скольких различных цветов должны использоваться при

передаче? б)Дан фргмент электронной таблица:Какое число должно быть записано в ячейкеВ1 ,чтобы построенная после выполнения вычеслений диаграмма по значениям диапозона ячеек А2:Д2 соответствовало рисунку

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

паскаль написать программу Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если сумма

первых двух чисел четна, то выведите эту сумму. Если сумма третьего и четвертого чисел четна и отрицательна, то выведите все четыре числа без изменения. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих четырех чисел. Иначе, выведите суммы двух первых и двух последних чисел.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз. Если выполняются одновременно 2 условия, то выведите эти числа без изменения. Иначе, выведите разность первого и последнего чисел.
Решить нужно в С или С++
Заранее спасибо!!!

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.
Решить нужно на среде С или С++
Заранее спасибо.



Вы находитесь на странице вопроса "Для произвольного числа, введенного с клавиатуры, найти сумму цифр кратных двум и меньших восьми", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.