Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Язык: Pascal

5-9 класс

Ошибка где то в присвоение, т.к на выходе все время получаю 0.
Вопрос: В чем же ошибка?
----------------------------------------
Program test;
var a, b, c, d: integer;
begin
writeln ('Enter A');
read (a);
writeln ('Enter B');
read (b);
writeln ('Enter C');
read (c);
if (a<b) and (a<c) then a:=d;
if (b<a) and (b<c) then b:=d;
if (c<a) and (c<b) then c:=d;
writeln ('Complete');
writeln ('Your number is', d);
end.

Ljkhjg 07 мая 2014 г., 15:43:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мэри56
07 мая 2014 г., 17:19:22 (9 лет назад)

d:=a; d:=b; d:=c;                         
а то у тебя d равно нулю

+ 0 -
Nookie16
07 мая 2014 г., 18:34:09 (9 лет назад)

d присваивай

+ 0 -
Jennu
07 мая 2014 г., 19:49:45 (9 лет назад)

d:=a и вниз по списку

+ 0 -
Veselovanastia
07 мая 2014 г., 20:40:53 (9 лет назад)

Точно спс

Ответить

Читайте также

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal

Написать выражения на языке Pascal
Ребят задача на языке Pascal...

Дано целое число, если оно двузначное, то умножить на 2, в противном случае вычесть 10.

Помогите решить задачку в паскале ! Пожалуйста !

Составить программу на языке Pascal для решения следующей логической задачи.
По графику нужно написать задачу и решение, график прилагается.

Помоги мне пожалуйста это очень важно

Написать программу суммы двух целых чисел на языке Pascal



Вы находитесь на странице вопроса "Язык: Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.