Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

информационное сообщение на русском языке, первоначально записанное в 8-битовом коде windows, было перекодировано в 16-битовую кодировку unicod. В

5-9 класс

результате информационный объем сообщения стал равен 2 Мбайта. Найдите кол-во символов в сообщении

Aida1 10 мая 2014 г., 16:56:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
фунтик999
10 мая 2014 г., 19:37:56 (9 лет назад)

При 16 битной кодировке на каждый символ приходится по 16 бит, объем сообщения равен 2 МБайта, нужно перевести в биты, 2 мбайта= 2*1024 байт=2*1024*8 бит= 16384 бит

Делим 16384 на 16 бит, получаем искомое кол-вл символов

16384/16=1024 

Ответить

Другие вопросы из категории

Язык: Pascal

Ошибка где то в присвоение, т.к на выходе все время получаю 0.
Вопрос: В чем же ошибка?
----------------------------------------
Program test;
var a, b, c, d: integer;
begin
writeln ('Enter A');
read (a);
writeln ('Enter B');
read (b);
writeln ('Enter C');
read (c);
if (a<b) and (a<c) then a:=d;
if (b<a) and (b<c) then b:=d;
if (c<a) and (c<b) then c:=d;
writeln ('Complete');
writeln ('Your number is', d);
end.

Составьте программу, используя оператор цикла с параметром:

S:=1(в квадрате)+2(в квадрате)+3(в квадрате)+...N(в квадрате).

Читайте также

Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке, первоначально записанного в 8-битном коде Windows-1251, в

16-битную кодировку Unicode, при этом информационный объём сообщения составил 160 байт. Определите информационный объём сообщения до перекодировки.

СРОЧНО Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке, первоначально записанного в 8-битном коде, в

16-битную кодировку Uicode. При этом информационное сообщение увеличелось на 2048 байт. Каков был информационный объем сообщения в Кбайтах до перекодировки

1. Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке первоначально записанного в 16-битном коде Unicode,в

8-битную кодировку КОИ-8. При этом информационное сообщение уменьшилось на 160 бит. Какова длина сообщения в символах?

Информационное сообщение на русском языке, первоначально записанное в 8- битовом коде КОИ- 8,было перекодировано в 16-битовую кодировку Unicode. В

результате его объем увеличился на 8000 битов. Найдите информационный объем сообщения до перекодировки

Информационное сообщение на русском языке, первоначально записанное в 8-битовом коде Windows, было перекодировано в 16-битовую кодировку Unicode. В

результате информационный объем сообщения стал равен 2 Мбайт. Найдите количество символов в сообщении.



Вы находитесь на странице вопроса "информационное сообщение на русском языке, первоначально записанное в 8-битовом коде windows, было перекодировано в 16-битовую кодировку unicod. В", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.