Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана

10-11 класс

последовательность слов. Напечатать
те слова последовательности, которые
отличны от последнего слова и удовлетворяют
следующему свойству: слово симметрично

OKROTTo 13 июля 2014 г., 4:44:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danyastartzev
13 июля 2014 г., 5:35:13 (9 лет назад)

uses
  System.Collections.Generic;

function reverse(const s: String): String;
begin
  if Length(s) = 1 then reverse := s else
    reverse := s[Length(s)] + reverse(Copy(s, 1, Length(s) - 1));
end;

var
  lst: List<string> := new List<string>();
  s, s1: string;

begin
  writeln('Конец последовательности - пустая строка');
  while (true) do
  begin
    readln(s);
    if (s.Length = 0) then
      break
    else
      lst.Add(s);
  end;
  writeln();
  foreach s in lst do
  begin
    if ((s <> lst.Last()) and (s = reverse(s))) then
      writeln(s);
  end;
end.

+ 0 -
504724
13 июля 2014 г., 7:06:36 (9 лет назад)

Язык какой?

Ответить

Другие вопросы из категории

В каких случаях могут быть опущены

отдельные этапы построения и исследования
модели?

4) Для какого названия животного ложно высказывание:

В слове 4 гласных буквы  ¬ (Пятая буква гласная)  В слове 5 согласных букв?
1) Шиншилла 2) Кенгуру 3) Антилопа 4) Крокодил
5) Для какого символьного набора истинно высказывание:
Вторая буква согласная  (В слове 3 гласных буквы  Первая буква согласная)?
1) УББОШТ 2) ТУИОШШ 3) ШУБВОИ 4) ИТТРАО

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Дана", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.