Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан фрагмент программы :

5-9 класс

a:= 10 ; b:= a+1 : a:=b-a ; write (a,b)
Какие числа будут выведены на экран компьютера ?

ромач 09 сент. 2014 г., 7:06:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
454854sany
09 сент. 2014 г., 8:47:59 (9 лет назад)

Решение
a:=10;
b:=(10)+1;
a:=(11)-10;

Ответ: a = 1 b = 11

Ответить

Читайте также

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

дан фрагмент программы на языке паскаль for i:=1 to 5 do for j:=1 to 5 do if (i+j) mod 2 <> 0 then write (скрыть крол

ика);

если применить данный алгоритм к матрице заполненной кроликами то сколько кроликов останутся нескрытыми?



Вы находитесь на странице вопроса "Дан фрагмент программы :", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.