Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Для массива X=(x1,x2,..,x50) найти наибольший элемент массива.Все элементы массива поделить на значение наибольшего элемента.

10-11 класс

Помогите пожалуйста)

Reg14 23 июля 2013 г., 7:54:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Voroninv
23 июля 2013 г., 9:48:26 (10 лет назад)

const
  n = 50;

var
  x: array[1..n] of real;
  max: real;
  i: integer;

begin
  Writeln('Введите ', n, ' элементов массива');
  max := -1e20; { число, заведомо меньшее вводимых }
  for i := 1 to n do
  begin
    Read(x[i]);
    if max < x[i] then max := x[i]
  end;
  Writeln;
  for i := 1 to n do
  begin x[i] := x[i] / max; Write(x[i], ' ') end;
  Writeln
end.

+ 0 -
гаареа
23 июля 2013 г., 12:34:26 (10 лет назад)

Gfcrfkm&

+ 0 -
Elshina
23 июля 2013 г., 13:59:37 (10 лет назад)

Ой.... Паскаль?

+ 0 -
JIeXu4
23 июля 2013 г., 14:39:21 (10 лет назад)

да

Ответить

Другие вопросы из категории

Тема паскаль:

Даны три массива A,B,C, состоящие из 10 элементов.Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.(4 стр, 10 столбцов, 0 до 10).Пожалуйста помогите кто умеет решать.Времени мало осталось.Заранее спасибо.
Например:
A B C D
1 2 3 (1+2+3)/3=2
2 3 4 (2+3+4)/3=3
3 4 5 (3+4+5)/3=4
4 5 6 (4+5+6)/3=5
5 6 7 (5+6+7)/3=6
6 7 8 (6+7+8)/3=7
7 8 9 (7+8+9)/3=8
8 9 10 (8+9+10)/3=9
9 10 11 (9+10+11)/3=10
10 11 12 (10+11+12)/3=11

сушествуют 3 действия Повернуть левый Повернуть правый диск по часовой стрелке Повернуть правый диск против часовой стрелки Повернуть левый

поворачивает левый диск на 180град Повернуть правый диск по часовой стрелке на 90град Повернуть правый диск против часовой стрелки на 90град

синий круг левый диск черыный - правый

превести мозайку в положение (во вложениях все)

награда 50 очков!

спасибо за решение

Читайте также

44 балла

Помогите решить две задачки (Паскаль)

Задание 1
Создать одномерный массив А, состоящий из сумм столбцов матрицы В(8,5). Определить в созданном массиве минимальный элемент и его местоположение, а также произведение всех элементов.

Задание 2
В двумерном массиве G(7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали. Заменить значение третьего элемента в первой строке на значение произведения.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Переменные x, x1, x2, x3 имеют размер - машинное полуслово, тип- знаковый, шестнадцатеричной системе счисления x1= C7(в основании 16) , x2 = D5(в

основании 16) , x3= AB (в основании 16). Вычислитьзначение выражения по правилам машинной арифметики x=(x1-x2)-x3, Вернуть его десятичной значение.

Помогите пожалуйста, задачка вузовская, 1 курс информационные технологии!

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)

написать программу для решения следующей задачи. В двумерном массиве,

состоящем из целочисленных элементов, поменять местами в каждой строке
наибольший и первый не принадлежащий интервалу (a, b) элементы.
(паскаль)



Вы находитесь на странице вопроса "Для массива X=(x1,x2,..,x50) найти наибольший элемент массива.Все элементы массива поделить на значение наибольшего элемента.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.