Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Программирование.Паскаль.Массивы

10-11 класс

1)Дан массив Р(15).Найти сумму всех отрицательных элементов с четными индексами.Полученный результат вывести на экран.

2)Ввести с пульта оператора массив МАС1 семь целых чисел. Переписать из МАС1 в МАС2 элементы значения которых положительные,в МАС3 элементы значения которых отрицательные. На пульт оператора вывести значения МАС1,МАС2,МАС3

Peoria 26 янв. 2014 г., 23:44:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeriya20010310
27 янв. 2014 г., 2:35:19 (10 лет назад)

program chik;
const n=15;
var P:array[1..15]of real;
i:integer;
s:real;
begin
s:=0;
for i:=1 to n do
begin
read(p[i]);
if(i mod 2=0)and(p[i]<0)then s:=s+p[i];
end;
writeln(s);
end.
2)
program gt;
uses crt,graphabc;
const n=7;
var mac1,mac2,mac3:array[1..15]of real;
i,k1,k2:integer;
begin
k1:=0;k2:=0;
for i:=1 to n do
begin
read(mac1[i]);
if(mac1[i]>0)then begin
Inc(k1);
mac2[k1]:=mac1[i];
end;
if(mac1[i]<0)then begin
Inc(k2);
mac3[k2]:=mac1[i];
end;
end;
for i:=1 to n do
write(mac1[i],' ');
writeln;
for i:=1 to k1 do
write(mac2[i],' ');
writeln;
for i:=1 to k2 do
write(mac3[i],' ');
end.

Ответить

Другие вопросы из категории

Сомнения!! Напиши в окне все буквы русского алфавита, для которых истинны утверждения: В русской алфавитной цепочке эта буква идёт позже буквы Ф. В

русской алфавитной цепочке следующая буква после этой буквы - гласная. Я думаю, что это Щ... НО Зачем-то дано большое окно для написания! И смущает в вопросе "все буквы"

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

Объем

оперативной памяти 512 Мб, а емкость жесткого диска 120 Гб. Во сколько раз
емкость жесткого диска больше, чем емкость оперативной памяти? Сделать вывод.

помогите срочно

Дано a=B3(16);.b=74(8) Выполнить действие a*b ответ представить в 2-й системе счисления.

Читайте также

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно

Заполнить массив T размерностью M значениями, введенными с клавиатуры.

Вывести на экран в одну строку каждый 2 элемент массива, который больше заданного значения K. (Язык программирования - Паскаль)

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Сформировать одномерный массив из 20 элементов (значения элементов задаются случайным образом). Вывести массива на

экран. Найти среднее арифметическое элементов первой половины массива и сумму элементов второй половины массива.

паскаль массивы



Вы находитесь на странице вопроса "Программирование.Паскаль.Массивы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.