Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано натуральное число n. Определить является ли оно простым или составным. Простым называется число, которое не имеет делителей кроме 1 и самого себя.

5-9 класс

Например, 17 и 43 - простые числа.Для решения задачи приведена программа с пропущенными строками. Необходимо в ответе записать содержание пустых строк, которое сделает программу правильной. Количество и расположение строк не менять.
Program Task;
Uses CRT;
Var n,i:integer;
b:boolean;
Begin
repeat
write('Число='); readln(n);
until n>0;
b:=true;
пропущена строка надо чтото записать
repeat
снова пропущена строка и надо что то записать
i:=i+1

10gafuza 10 нояб. 2014 г., 18:07:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Amirovdias
10 нояб. 2014 г., 18:52:52 (9 лет назад)

Я бы так написал:
var n,i:longint;
     b:boolean;
begin
  repeat
    write ('Число = ');
    readln(n);
  until n > 0;
  b:=false;
  for i:=2 to n div 2 do
   if n mod i = 0 then
    begin
      b:=true;
      break;
    end;
  if (not b) and (n <> 1) then writeln ('Простое') else writeln ('Составное');
  readln;
end.

Ответить

Другие вопросы из категории

Жители планеты альфа отправили на землю сообщение записанное с помощью всех символов используемого ими алфавита

МКЛКМНОНОПРОСТ!

Определите информационный объем этого сообщения

В бутылке,стакане,кувшине и в банке находятся молоко ,лимонад,квас и вода.Известно что вода и молоко не в бутылке ,сосуд с лимонадом стоит между

кувшином и сосудом с квасом.В каком сосуде находится каждая из жидкостей?помогите пожалуйста нужно нарисовать таблицу решения задачи

Помогите, пожалуйста, решить задачу по информатике 9 класса.Составить программу по паскалю. В тазу L литров варенья,которое необходимо разложить по

B-литровым банкам (L и B- целые числа).Сколько полных банок получится и сколько литров останется?

Читайте также

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то

вывести -1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "Дано натуральное число n. Определить является ли оно простым или составным. Простым называется число, которое не имеет делителей кроме 1 и самого себя.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.