Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

6. Написать программу тремя способами ( с циклами «ДО», «ПОКА» и с параметром ). Задача: Ввести n чисел. Найти сумму четных из них. Проанализируйте

5-9 класс

решения. Какое проще и почему?

микимики86 20 дек. 2014 г., 19:09:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Holin64
20 дек. 2014 г., 21:25:29 (9 лет назад)

uses crt;

var s,n,ch:integer;

begin

for i:=1 to n do

begin

if ch mod 2 = 0 then

s:=s+ch;

end;

end.

 

uses crt;

var s,n,ch,i:integer;

begin i:=1;

while i <=n do

begin

if ch mod 2 = 0 then

s:=s+ch; inc(i);

end;

end.

 

 

uses crt;
var s,n,ch,i:integer;
begin i:=1;
n:=5;
repeat
begin
readln(ch);
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
until i>=n;

writeln(s);
end.

Ответить

Другие вопросы из категории

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

Пожалуйста помогите.

Сформулируйте как нужно защищаться от негативных последствий информатизации в своем компьютере?

Паскаль.

вводятся числа, последнее число "0", определить сколько в них положительных нечетных и найти сумму отрицательных.
Помогитеее!!

Читайте также

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и

написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:

k:=1;

f:=0;

while k<n do

f:=f*k;

k:=k+1

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).



Вы находитесь на странице вопроса "6. Написать программу тремя способами ( с циклами «ДО», «ПОКА» и с параметром ). Задача: Ввести n чисел. Найти сумму четных из них. Проанализируйте", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.