Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С++

10-11 класс

одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение

RolePlayer 13 марта 2015 г., 18:44:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dbhjjjcdcf
13 марта 2015 г., 19:36:27 (9 лет назад)

    int sum = 0,pro = 1;
    int A[15];
    for (int i=0;i<15;i++)
    {
        cin>>A[i];
    }
    for (int i=0;i<15;i++)
    {
        if (A[i]>0) sum = sum+A[i];
         else if (A[i]<0) pro = pro * A[i];
    }
    cout<<"Cумма положительных: "<<sum;
    cout<<"Произведение отрицательных: "<<pro;
    if (sum>pro) cout<<"Cумма больше";
     else if (sum<pro) cout<<"Произведение больше";
      else cout<<"Числа равны";
    return 0;

Ответить

Другие вопросы из категории

дан массив из 30-ти элементов. Каждый элемент может принимать целочисл

енные значения от -100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. Первый элемент не равен 0. (Паскаль)

1)Вывести в обратном порядке второе слово строки. Подсчитать количество букв в нем.

2) Составить программу для вычисления Т=(R/Q+1)+S. R - наименьший элемент массива;
Q - произведение элементов массива с нечетными номерами;
S - количество элементов, лежащих в интервале (A,B) (ввести с клавиатуры).
3) Вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже
побочной диагонали. Закрасить указанные элементы.

1) Алгоритм

вычисления значения функции F(n), где n – натуральное число, задан следующими
соотношениями:

Читайте также



Вы находитесь на странице вопроса "С++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.