Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)Вывести в обратном порядке второе слово строки. Подсчитать количество букв в нем.

10-11 класс

2) Составить программу для вычисления Т=(R/Q+1)+S. R - наименьший элемент массива;
Q - произведение элементов массива с нечетными номерами;
S - количество элементов, лежащих в интервале (A,B) (ввести с клавиатуры).
3) Вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже
побочной диагонали. Закрасить указанные элементы.

XSokolov1993 04 февр. 2015 г., 15:47:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Бирошка
04 февр. 2015 г., 17:32:47 (9 лет назад)

var
  x: string;
  arr: array of char;

begin
  readln(x);
  arr := x.Split(' ')[1].ToCharArray();
  System.Array.Reverse(arr);
  writeln(length(arr), '   ', new string(arr));
end.
---------------------------------------
var
  c: array of integer := (10, 20, 10, 30, 40, 50, 55, 1, 5, 9, 4, 3, 2);
  r, q, s: real;
  i, a, b: byte;
  
begin
  q := 1;
  i := 1;
  r := c.Min();
  while (i < length(c)) do
  begin
    q *= c[i];
    i += 2;
  end;
  readln(a, b);
  s := b - a - 1;
  writeln('T = ', (R / Q + 1) + S);
end.
-----------------------------
const
  k = 5;
  p = 5;

var
  f: array [1..k, 1..p] of string;
  o: real;
  df: byte;

begin
  for i: byte := 1 to k do
  begin
    for j: byte := 1 to p do
    begin
      f[i, j] := random(10, 99).ToString();
      write(f[i, j]:3);
      if (j >= 7 - i) then
      begin
        o += integer.Parse(f[i, j]);
        df += 1;
        f[i, j] := '██';
      end;
    end;
    writeln();
  end;
  writeln();
  for i: byte := 1 to k do
  begin
    for j: byte := 1 to p do
      write(f[i, j]:3);
    writeln();
  end;
  writeln(o / df);
end.

Ответить

Другие вопросы из категории

1) Алгоритм

вычисления значения функции F(n), где n – натуральное число, задан следующими
соотношениями:

Для чего нужен ooo writer
Помогите только 1 номер.

Читайте также

В введенной строке подсчитать количество слов, что одинаково начинаются и заканчиваются

(Примечание: Слова в текстовой строке отделены пробелами или группами пробелов.

16. Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы «AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту за первой, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево). Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

16.1. С какой буквы начинается 13-я строка?

16.2. Сколько раз буква А встречается в 10-ой строке?

16.3. Какая буква стоит на 8-ой позиции в 11-ой строке?

16.4. Сколько раз встречается буква А в первых семи строках (суммарно)?

5.1 Ввести

с клавиатуры строку символов. Признак окончания ввода строки – нажатие клавиши
"Ввод". Программа должна определить длину введенной строки L, и, если
длина L >6, то выделяется подстрока в { } скобках.



5.2 Дана
строка. Подсчитать количество букв k в последнем его слове.

Даны натуральное число n, символы s1,...sn. , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя ,

будем называть словами. подсчитать количество букв a в последнем слове данной последовательности

В TPascal

помогите пожалуйста:

Напиши цифровой фильтр. На вход программе подаётся строка символов. На выходе должны быть только её цифры. Например, если на входе была строка
He110, k177en!
то на выходе должно быть
110177

2. В строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. Например, если на вход программе подавалась строка
Меня истина манит сияньем
то на выходе будет
истина

На вход подаётся строка. Вывести часть входной часть строки. Часть строки задаётся номером первого символа и количеством символов.

var
s: string;
n, k, i: integer;
Begin
readLn(s, n, k);
for i := n to n+k-1 do write(s[i]);
End.


2. На вход подаётся предложение на английском языке. Вывести все гласные строки в том порядке, в котором они встречались в строке.


(ключевой фрагмент)
for i := 1 to length(s) do
if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
then write(s[i]);


Варианты программы определения, является ли строка полиндромом
--------------------------------------------------------------
var
s, s1: string;
i: integer;
Begin
readLn(s);
s1 := '';
for i := 1 to length(s) do s1 := s[i] + s1;

write('строка ');
if s1 <> s then write('не ');
writeLn('является полиндромом');
End.



var
s: string;
i, j: integer;
Begin
readLn(s);

i := 1;
j := length(s);
while (i < j) and (s[i] = s[j]) do begin
inc(i);
dec(j);
end;
write('строка ');
if s[i] <> s[j] then write('не ');
writeLn('является полиндромом');
End.




Вы находитесь на странице вопроса "1)Вывести в обратном порядке второе слово строки. Подсчитать количество букв в нем.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.