Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

5.1 Ввести

10-11 класс

с клавиатуры строку символов. Признак окончания ввода строки – нажатие клавиши
"Ввод". Программа должна определить длину введенной строки L, и, если
длина L >6, то выделяется подстрока в { } скобках.



5.2 Дана
строка. Подсчитать количество букв k в последнем его слове.

2350001650701 08 нояб. 2013 г., 16:04:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MuIIIa
08 нояб. 2013 г., 18:46:36 (10 лет назад)


var
  l,a,b:integer;
  s: string;
begin
write('Введите строку: ');
readln(s);
l:=length(s);
writeln('L=',l);
if l>6 then
   begin
   a:=pos('(',s);
   b:=pos(')',s);
   if (a>0) and (b>0) then writeln(copy(s,a+1,b-a-1));
   if (a=0) and (b>0) then writeln('Скобка не открыта');
   if (a>0) and (b=0) then writeln('Скобка не закрыта');
   if (a=0) and (b=0) then writeln('Текста в скобках нет');
  end;
end.


var
  n,i,k:integer;
  s,t: string;
begin
write('Введите строку: ');
readln(s);
t:=s;
repeat
  i:=pos(' ',t);
  delete(t,1,i);
  until i=0;
k:=length(t);
for i:=1 to k do
  if t[i]='k' then n:=n+1;
writeln('Кол-во букв k: ',n);
end.

+ 0 -
Okay55
08 нояб. 2013 г., 19:42:48 (10 лет назад)

А если в тексте скобок нет, то и ничего не печатаем?

+ 0 -
Pragress0r
08 нояб. 2013 г., 20:52:17 (10 лет назад)

Тогда написать что нет скобок

+ 0 -
Gena99
08 нояб. 2013 г., 22:01:16 (10 лет назад)

А скобки какие? А то в задании фигурные, а здесь ты простые пишешь.

+ 0 -
Залпа
09 нояб. 2013 г., 0:27:34 (10 лет назад)

да можно простые()

+ 0 -
Varvarager
09 нояб. 2013 г., 1:06:33 (10 лет назад)

ещё кстати может быть, то что одна скобка открыта, а другой нет, то написать " что не закрыта(открыта) скобка"

Ответить

Другие вопросы из категории

33. Последовательность чисел

Вводится последовательность целых чисел, заканчивающаяся нулем. Преобразовывать последовательность следующим образом:

1) заменить отрицательные числа в последовательности на их модули и вывести получившуюся последовательность;

2) в полученной последовательности заменить четные числа на максимальное число последовательности, вывести результат;

3) в полученной последовательности вычесть из каждого члена последовательности 2, вывести результат;

4) в полученной последовательности заменить отрицательные на 0, вывести результат.



Пример.

Последовательность: 1 2 3 0

1) 1 2 3

2) 1 3 3

3) –1 1 1

4) 0 1 1

на Pascale

Дано натуральное число n (n<9999). Найти предпоследнюю цифру числа ( в предположении, что n>10).

Пожалуйста помогите!

Составьте программу вычисления в массиве А(10), заполненном случайными числами из интервала [-1;6], суммы всех элементов массива.

Читайте также

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Помогите пожалуйста сделать!!!! В пасккале! 1.Ввести любую букву определить гласная или нет

2.Ввести число . определить четное или не

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да



Вы находитесь на странице вопроса "5.1 Ввести", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.