Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

на Pascale

10-11 класс

Дано натуральное число n (n<9999). Найти предпоследнюю цифру числа ( в предположении, что n>10).

Спасушка 15 сент. 2013 г., 3:23:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daryaderyabina
15 сент. 2013 г., 5:06:42 (10 лет назад)

var
  n:integer;
  c:string;
begin
  write('Введите число от 10 до 9999 ->');
  readln(n);
  Str(n,c);
  writeln('Предпоследняя цифра в числе равна ',c[length(c)-1])
end.

Пример работы программы:

Введите число от 10 до 9999 ->1523
Предпоследняя цифра в числе равна 2


Ответить

Другие вопросы из категории

Пожалуйста помогите!

Составьте программу вычисления в массиве А(10), заполненном случайными числами из интервала [-1;6], суммы всех элементов массива.

Решите уравнение:

2_{5}(x + 1321_{4} )=11 C_{16}
Ответ запишите в семеричной системе счисления.

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Код программы "Тест" на Pascal

Необходимо написать код программы в формате .txt , чтобы на экране выводилось следующее:

1. Выводится текст "Вам предлагается тест на тему "Поведение в кабинете информатики""

2. Выводится вопрос и несколько вариантов ответа.

3. Выводится "Выберите № ответа".

4. Вопросов всего 3.

5. Выводится "Тест окончен".

6. Выводится "Оценка: Зачет" или "Оценка: Незачет"

Вот сами вопросы:
1. На каком расстоянии от монитора должен
работать ученик за компьютером?

a) 15-20 см

b) 50-70 см

c) Меньше 40 см
d) 90-110 см
2. Можно ли класть тетради, книги, диски на
монитор и клавиатуру?

a) Можно.

b) Можно только на клавиатуру.

c) Можно только на монитор.

d) Нельзя.
3. При появлении запаха гари нужно…

a) Бежать за водой, чтобы предотвратить
дальнейшее возгорание.

b) Прекратить работу, сообщить
преподавателю
c) Не обращать внимания
d) Быстро убежать из кабинета

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Пожалуйста напишите программу на pascal.

Вывести все четырехзначные, у которых все цыфры разные, кратные К и произведение цифр которых равно числу N.



Вы находитесь на странице вопроса "на Pascale", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.