Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Пожалуйста,помогите решить задачи на Pascale!

10-11 класс

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Glamsy 21 марта 2015 г., 10:37:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ariell83
21 марта 2015 г., 13:26:58 (9 лет назад)

const n=7; m=8;
Var a:array[1..n,1..m] of integer;
i,j,x,y,min:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write(a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
x:=1;
y:=1;
for i:=1 to n do
for j;=1 to m do 
if a[i,j]<min then begin
min:=a[i,j];
x:=i;
y:=j;
end;
writeln ('минимальный элемент=',min,' он находился: ',x,',',y);
a[x,y]:=100;
for i:=1 to n do begin
for j:=1 to n do 
write (a[i,j]:4);
writeln;
end;
end.

3.Var s:string;
i:integer;
begin
writeln('Введи строку');
readln (s);
for i:=1 to length(s) do
if (s[i]='Е') or (s[i]='е') then delete(s,i,1);
writeln(s);
end.

+ 0 -
Aram1999
21 марта 2015 г., 14:58:06 (9 лет назад)

какой класс?

+ 0 -
чсмт
21 марта 2015 г., 16:39:41 (9 лет назад)

2 курс)

+ 0 -
Dhyjsb
21 марта 2015 г., 19:08:24 (9 лет назад)

понятно,когда нужно сделать?

+ 0 -
элиночкаа
21 марта 2015 г., 20:52:37 (9 лет назад)

желательно сегодня

Ответить

Другие вопросы из категории

32. Цвет пикселя монитора определяется тремя составляющими: зеленой, синей и красной. Под красную и синюю составляющие отвели по 5 бит. Сколько бит отвели

под зеленую составляющую, если растровое изображение размером 8(8 пикселей занимает 128 байт?

Задачи на двумерный массив. Задание

1.

63. Какой из критериев не является необходимым при оценке эффективности внедрения информационных технологий? а) конкурентное положение организации в

области информационных технологий, ее конкурентные преимущества и отставания; б) безопасная внутренняя информационная структура предприятия; в) эффективность вложения средств в оборудование и обучение персонала; г) возможность получения прямой или косвенной финансовой отдачи от вложений в информационные технологии;

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова



Вы находитесь на странице вопроса "Пожалуйста,помогите решить задачи на Pascale!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.