Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задачи на двумерный массив. Задание

10-11 класс

1.

Alisheikh736 24 янв. 2015 г., 18:23:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
RaminaElisabet
24 янв. 2015 г., 19:20:57 (9 лет назад)

Задание 3 (двухмерный массив)

var

a:array [1..10,1..7] of integer;

k,i,j:integer;

begin

randomize;

for i:=1 to 10 do begin

for j:=1 to 7 do begin

a[i,j]:=random(9)+1;

write (a[i,j]:4);

if a[i,j] mod 2 <> 0 then k:=k+1;

end;

writeln;

end;

writeln ('Количество нечетных элементов массива = ',k);

readln;

end.

Задание 2 (двухмерный массив)

uses crt;
const
a:array [1..5,1..5] of integer = ((100,101,102,103,104),
                                                     (200,201,202,203,204),
                                                     (300,301,302,303,304),
                                                     (400,401,402,403,403),
                                                     (500,501,502,503,504));
var
i,j:integer;
begin
clrscr;
for i:=1 to 5 do begin
for j:=1 to 5 do
if j mod 2 = 0 then begin
textcolor (12);
write (a[i,j]:4);
textcolor (7);
end else begin
textcolor (9);
write (a[i,j]:4);
textcolor (7);
end;
writeln;
end;
readln;
end.

Задание 1 (одномерный массив) 

uses crt;
var
a:array [1..7] of integer;
i,sum:integer;
begin
clrscr;
for i:=1 to 7 do begin
write ('A[',i,'] = ');readln(a[i]);
if a[i]>0 then sum:=sum+a[i];
end;
for i:=1 to 7 do
if a[i]>0 then begin
textcolor (red);
write (a[i]:4);
end else begin
textcolor (blue);
write (a[i]:4);
end;
writeln;
textcolor (darkgray);
writeln ('Сумма положительных элементов = ',sum);
readln;
end.

Задание 4 (одномерный массив)

uses crt;
var
a:array [1..12] of integer;
i,buf,min,max:integer;
begin
clrscr;
randomize;
a[1]:=random(14)+1;
min:=1;
max:=2;
writeln ('Исходный массив: ');
write (a[1]:4);
for i:=2 to 12 do begin
a[i]:=random(14)+1;
write (a[i]:4);
if a[i]>a[max] then max:=i else
if a[i]<a[min] then min:=i;
end;
writeln;
{смена 1-ого и последнего эл}
buf:=a[1];
a[1]:=a[12];
a[12]:=buf;
{смена 2-ого и мин эл}
buf:=a[2];
a[2]:=a[min];
a[min]:=buf;
{смена 1-ого и макс эл}
buf:=a[1];
a[1]:=a[max];
a[max]:=buf;
writeln ('Результирующий массив:: ');
for i:=1 to 12 do write (a[i]:4);
writeln;
readln;
end.

Задание 3 (одномерный массив)

var
a,b:array [1..10] of integer;
i,j:integer;
s1,s2:real;
begin
randomize;
s1:=0;
s2:=0;
writeln;
for i:=1 to 10 do begin
a[i]:=random(11)-5;
b[i]:=random(19)-9;
write (a[i]:4);
s1:=s1+a[i];
s2:=s2+b[i];
end;
writeln;
for i:=1 to 10 do write (b[i]:4);
writeln;
s1:=s1/10;
s2:=s2/10;
if s1>s2 then writeln ('S1 > S2') else
if s1<s2 then write ('S1 < S2') else writeln ('S1 = S2');
readln;
end.

Ответить

Другие вопросы из категории

63. Какой из критериев не является необходимым при оценке эффективности внедрения информационных технологий? а) конкурентное положение организации в

области информационных технологий, ее конкурентные преимущества и отставания; б) безопасная внутренняя информационная структура предприятия; в) эффективность вложения средств в оборудование и обучение персонала; г) возможность получения прямой или косвенной финансовой отдачи от вложений в информационные технологии;

дайте несколько возможных общих имен каждой группе объектов.Выберите. из них самое подходящее.

ответ обоснуйте:
а)Перу,Чили,Эквадор;
б)Эркюль Пуаро,Шерлок Холмс,комиссар Мегрэ;
в)Москва,Санкт-Петербург,Новосибирск;
г)Конго,Нил,Замбези;
д)повесть "Капитанская дочка",роман "Евгений Онегин",стихотворение"Туча"
е)Москва,Санкт-Петербург,Тула.

2)Массив 4*4

0010
0100
0000
1100

Ребят, помогите с задачей. Буду признательна ,если подробно решение распишете.Первоначально сообщение на русском языке было записано в 16-битном

коде Unicode. При его перекодировке в 8-битную кодировку КОИ-8 информационное сообщение уменьшилось на 800 бит. Сколько символов в сообщении?

Читайте также

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив. Задание 2.

Заполнить двухмерный массив NM [1..5,1..5] константами:

100 101 102 103 104
200 201 202 203 204
300 301 302 303 304
400 401 402 403 404
500 501 502 503 504

В задаче на двумерный массив сделать файловый вывод. Вот само решение задачи.

var a:array[1..12,1..10] of integer;
i,j:integer;
begin
for i:=1 to 10 do
a[1,i]:=i*12;
for i:=2 to 12 do
for j:=1 to 10 do
a[i,j]:=a[i-1,j]-1;
for i:=1 to 12 do begin
for j:=1 to 10 do
write(a[i,j]:4);
writeln;
end;
end.

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835



Вы находитесь на странице вопроса "Задачи на двумерный массив. Задание", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.