Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В задаче на двумерный массив сделать файловый вывод. Вот само решение задачи.

10-11 класс

var a:array[1..12,1..10] of integer;
i,j:integer;
begin
for i:=1 to 10 do
a[1,i]:=i*12;
for i:=2 to 12 do
for j:=1 to 10 do
a[i,j]:=a[i-1,j]-1;
for i:=1 to 12 do begin
for j:=1 to 10 do
write(a[i,j]:4);
writeln;
end;
end.

Shalyaginayuli1 23 апр. 2015 г., 0:02:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annakroxa
23 апр. 2015 г., 2:14:01 (9 лет назад)

var
  a: array[1..12, 1..10] of integer;
  i, j: integer;
  f: Text;

begin
  Assign(f, 'Output.txt');
  Rewrite(f);
  for i := 1 to 10 do
    a[1, i] := i * 12;
  for i := 2 to 12 do
    for j := 1 to 10 do
      a[i, j] := a[i - 1, j] - 1;
  for i := 1 to 12 do
  begin
    for j := 1 to 10 do
      write(f, a[i, j]:4);
    writeln(f)
  end;
end.

+ 0 -
янад65
23 апр. 2015 г., 4:30:26 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Решите в паскале ABC .

Известно время полета вылета самолета - HH часов и ММ
минут, а также продолжительность полета (НР часов и МР минут). Напечатать время
прибытия самолета в аэропорт назначения в виде: самолет прибывает в
12.35. Учесть возможность перехода часов (после 23.59 наступает 00.00).

Для передачи по каналу связи сообщения, состоящего только из символов А, Б, В и Г, используется посимвольное кодирование: А – 00, Б – 11, В – 010, Г –

011. Через канал связи передаётся сообщение: ВБГАГВ.Закодируйте сообщение данным кодом. Полученное двоичное число переведите в шестнадцатеричный вид.

Как пройти 7 уровень час кода

Читайте также

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив. Задание 2.

Заполнить двухмерный массив NM [1..5,1..5] константами:

100 101 102 103 104
200 201 202 203 204
300 301 302 303 304
400 401 402 403 404
500 501 502 503 504

Задачи на двумерный массив. Задание

1.

Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.

Составить программу, которая
вводит данные о студентах:

№ п/п, фамилию, год рождения, пол, курс, вид спорта и выводит:

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.



Вы находитесь на странице вопроса "В задаче на двумерный массив сделать файловый вывод. Вот само решение задачи.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.