Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.

10-11 класс

Составить программу, которая
вводит данные о студентах:

№ п/п, фамилию, год рождения, пол, курс, вид спорта и выводит:

Wiktoriya28 19 апр. 2015 г., 23:59:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cnuj
20 апр. 2015 г., 1:04:38 (9 лет назад)

const n=3;
type student=record
fam:string[20];
year:integer;
sex:string[1];
kurs:integer;
sport:string[30];
end;
var x:array[1..n] of student; i,j:integer;
p:student;
begin
for i:=1 to n do
with x[i] do begin
writeln('сведенья о ',i,' студенте:');
writeln('фамилия: ');
read(fam);
writeln('год рождения: ');
read(year);
writeln('пол( м или ж ): ');
read(sex);
writeln('курс: ');
read(kurs);
writeln('вид спорта: ');
read(sport);
end;

for i:=1 to n-1 do
for j:=i+1 to n do
if x[i].fam>x[j].fam then begin
p:=x[i];
x[i]:=x[j];
x[j]:=p;
end;
for i:=1 to n do begin
with x[i] do
if (sex='ж') then writeln('Фамилия студентки: ',fam,' Курс: ',kurs,' Вид спорта:  ',sport);
end;
end.

+ 0 -
Nicki26
20 апр. 2015 г., 3:27:44 (9 лет назад)

Спасибо, я очень Вам благодарна.

+ 0 -
DianaVladimirovna
20 апр. 2015 г., 4:11:21 (9 лет назад)

Пока еще не за что благодарить

+ 0 -
MarinaSosnovceva
20 апр. 2015 г., 6:45:58 (9 лет назад)

Я еще даже не начала, скоро сяду

+ 0 -
Mkoval1
20 апр. 2015 г., 8:07:15 (9 лет назад)

Но всё же Вы одна откликнулись.

+ 0 -
124саня
20 апр. 2015 г., 10:03:18 (9 лет назад)

Готово)

Ответить

Другие вопросы из категории

Счастливым считается билет с 6 значным номером, у которого сумма первых 3 цифр равна сумме послед 3. Напечатать номера счастливых билетов. Пожалу

йста, решите, буду очень благодарна!

ПАСКАЛЬ, БЕЗ ВСЯКИХ СЛОЖНОСТЕЙ, НА ШКОЛЬНОМ УРОВНЕ 10 КЛАССА:)

ребята нужна помощь,очень важно в turbopascal решить занести в файл 3 записи,каждая из которых представляет

собой совокупность трех полей:фамилия ,год рождения,женат или нет

Иванов 1970 да

Петров 1972 нет

Сидоров 1969 да.

распечатать содержимое полученного файла

Затем считать из файла эту информацию и напечатать:

1-я запись-Иванов 1970 да

2-я запись-Петров 1972 нет

3-я запись-Сидоров 1969 да

Читайте также

Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Здравствуйте,

помогите с задачей на PascalABC.

Найти и вывести все шипящие буквы ( без повторений ), которые встретились в самом длинном слове.

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.



Вы находитесь на странице вопроса "Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.