Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте,

10-11 класс

помогите с задачей на PascalABC.

Найти и вывести все шипящие буквы ( без повторений ), которые встретились в самом длинном слове.

Ksu0309sha 28 мая 2013 г., 13:55:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Микадо
28 мая 2013 г., 15:59:00 (10 лет назад)

var
  a: array [1..4] of char;
  s: string;
  i: byte := 1;
begin
  readln(s);
  while (i < length(s)) do
  begin
    if ((not(s[i] in ['ж', 'ч', 'ш', 'щ'])) or (pos(s[i], s) > i)) then
      delete(s, i, 1)
    else
      i += 1;
  end;
  writeln(s);
end.

Суть в том, чтобы удалить все нешипящие буквы, а также повторы шипящих, после чего просто вывести строку

Ответить

Другие вопросы из категории

1.Почему современные персональные компьютеры в сотни раз меньше но при этом в сотни раз быстрее эвм первого поколения?

2.Почему современные персональные компьютеры доступен для массового потребления?

Срочно! Ответьте, пожалуйста!!!

Класс может иметь интерфейс для доступа к его экземплярам извне. Он реализуется модификаторами доступа:


1. private

2. inline

3. public

4. protected

5. static

Когда выйдет джейл брейк на ios 7 ???
Исследуйте школу,как систему:

Какого типа эта система:естественная или искусственная;
Выделите входящие в нее подсистемы;
Выделите материальные и информационные связи;
Какие изменения в структуре школы следует сделать,чтобы она лучшим
образом выполняла своё назначение?

Читайте также

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить. На

острове каждый год появляется сундук с 100 кг золотого песка, к острову с одной стороны высаживается х пиратов, а с другой у матросов. Они дерутся за клад, в битве погибает 70% участников, 26% тяжело ранены. Монеты делятся среди оставшихся 4%. Определить количество победителей, тяжелораненых, погибших, а также количество золотого песка на 1 человека .

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

Здравствуйте, решите, пожалуйста, 1,2,5,7,8,9,10.


Вы находитесь на странице вопроса "Здравствуйте,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.