Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

10-11 класс

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

Denic2002 03 дек. 2014 г., 6:37:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Вик18
03 дек. 2014 г., 9:11:27 (9 лет назад)

var
  i : integer;
  aa : array[1..9] of integer;

begin
  { высчитываем элементы массива }
  for i := 1 to 9 do
    if i mod 3 = 1 then
      aa[i] := (i + 5) * (i + 5)
    else if i mod 3 = 2 then
      aa[i] := round(sqrt(aa[i-1]))
    else
      aa[i] := aa[i-1] div aa[i-2];
  { выводим значения на экран }
  for i := 1 to 9 do
    write(aa[i], ' ');
end.

Ответить

Другие вопросы из категории

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

Читайте также

Помогите решить задачи.

1.Сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:
1-й равен случайному двузначному числу;
2-й равен целой части от деления случайного трехзначного числа на его индекс;
3-й равен остатку от деления случайного двузначного числа на 10.
2.

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.